Opened 14 years ago

Closed 10 years ago

Last modified 8 years ago

#2408 closed defect (fixed)

killproc killing children first

Reported by: DJ Lucas Owned by: blfs-book@…
Priority: normal Milestone:
Component: Bootscripts Version: SVN
Severity: major Keywords:
Cc:

Description

Just a reminder so it's not forgotten, labeled as a blocker. I don't see the errors because I use contrib bootscripts (and homegrown). Currently reported are httpd and samba scripts. Adding -p $PIDFILE to the killproc line is reported as a working solution.

Change History (10)

comment:1 by dnicholson@…, 14 years ago

Owner: changed from blfs-book@… to dnicholson@…
Status: newassigned

Committed a fix for samba in r7121. Note that httpd is OK because we use the apachectl script, which knows how to handle httpd correctly (I think). r7122 has a few more scripts where I know that referencing the pid file in /var/run works. I just fixed that ones that are currently running on my system. Feel free to add more.

Leaving this open for now in case anyone else spots scripts where this process handling is not correct. I tend to think that anything that puts creates a pidfile should be calling the *proc functions with that info.

comment:2 by dnicholson@…, 14 years ago

So, I found out a little later that the LFS bootscripts are buggy when passing "-p $pidfile". The problem is that if there's a stale pid file hanging around, loadproc will bail out. This becomes a big problem if you've had to hard reboot and have a lot of stale pid files. In that case, you have to go and manually remove all the stale pid files or you won't get any services you might need.

The right way to fix this is to teach the *proc functions what to do in the face of a stale pid file. However, any fixes will be on LFS trunk (I do plan on doing this since it bites me frequently). Since we're targeting LFS-6.3, I'm going to back out r7122. I'll leave the samba fix in r7121 there since it fixes a bigger issue.

Does that sound alright?

comment:3 by dnicholson@…, 14 years ago

Milestone: 6.37.0

Backed out the changes in r7265. Changing the milestone to 7.0 when we can depend on a proper fix in the LFS bootscripts. See LFS #2160 (http://wiki.linuxfromscratch.org/lfs/ticket/2160).

comment:4 by Randy McMurchy, 14 years ago

Milestone: 7.0future
Severity: blockermajor

Simply changing the Milestone to 'Future' as we don't know when LFS-7.0 is going to appear (there could be a BLFS-6.3.1 after BLFS-6.3?).

Additionally, there are only one or two flagged as 7.0 so marking it future makes it easier to use the filters.

Also changing the "Blocker" as that conflicts with it not being a 6.3 bug.

comment:5 by Randy McMurchy, 13 years ago

Milestone: future6.4
Owner: changed from dnicholson@… to blfs-book@…
Status: assignednew
Type: taskdefect

comment:6 by Randy McMurchy, 12 years ago

Milestone: 6.46.5

Modified milestone from 6.4 to 6.5

comment:7 by (none), 11 years ago

Milestone: 6.5

Milestone 6.5 deleted

comment:8 by Randy McMurchy, 11 years ago

Milestone: 6.7

Updated milestone to 6.7

comment:9 by bdubbs@…, 10 years ago

Resolution: fixed
Status: newclosed

Closing. LFS-7 now uses /run for pid files so there will be none in a reboot situation.

Reopen as necessary.

comment:10 by bdubbs@…, 8 years ago

Milestone: 6.7

Milestone 6.7 deleted

Note: See TracTickets for help on using tickets.