Opened 15 years ago

Closed 14 years ago

#2415 closed defect (fixed)

sed command in GNOME Doc Utils

Reported by: Chris Staub Owned by: Randy McMurchy
Priority: normal Milestone: 6.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

The first thing in the instructions for GNOME Doc Utils is:

sed -i 's/@.*@pkgconfig/pkgconfig/' Makefile.in

However, when I run this it doesn't appear to do anything. I tried searching Makefile.in for instances of "pkgconfig" and can't find anything.

Change History (5)

comment:1 by Randy McMurchy, 15 years ago

Type: taskdefect

Dan put this into the Gnome Doc Utils page a long time ago. (http://wiki.linuxfromscratch.org/blfs/changeset/6341/trunk/BOOK/gnome/core/gnome-doc-utils.xml)

My build script doesn't have it as I would have Python installed.

Not sure about the version Dan updated, but the current book version of GNOME Doc Utils Makefile.in has PKG_CONFIG in it, not pkgconfig. Not sure if we still need it or not.

Perhaps Dan can look into this to see if it is still needed. (though I don't know why we do as we recommend that Python be installed. If folks don't want to follow our recommendation, I don't feel bad about saying to these folks, "You're on your own".)

comment:2 by Randy McMurchy, 14 years ago

Owner: changed from blfs-book@… to Randy McMurchy
Status: newassigned

This is not required any longer. Tested and confirmed by installing GDU with --disable-build-utils which won't build Python hooks. pkgconfig file is installed as it should

comment:3 by Randy McMurchy, 14 years ago

After futher review, indeed the xml2po.pc file is not installed if GDU is built without Python. Will do more testing.

comment:4 by Randy McMurchy, 14 years ago

Okay, the existing sed does nothing as the Makefile.in has changed since Dan put the sed in.

Apparently what the sed did was allow the xml2po.pc file to be installed regardless of the Python installation. But this is no good. The xml2po.pc file is put there because if Python is found, then a Python script named xml2po is placed in the ../bin dir.

To me, the .pc file should only exist if the actual Python script also exists.

Removing the sed.

comment:5 by Randy McMurchy, 14 years ago

Resolution: fixed
Status: assignedclosed

Removed the sed command from the GNOME Doc Utils instructions.

Note: See TracTickets for help on using tickets.