Opened 14 years ago

Closed 12 years ago

Last modified 11 years ago

#2419 closed task (fixed)

GnuTLS-2.8.1

Reported by: Randy McMurchy Owned by: Wayne Blaszczyk
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Change History (15)

comment:1 by Randy McMurchy, 14 years ago

Milestone: 6.3future
Summary: GnuTLS-2.0.4GnuTLS-2.3.4

Version increment to 2.3.4

Reviewing the ChangeLog reveals many API/ABI changes since the version currently in BLFS. It says that many applications just need to be recompiled, but there were also changes to the OpenPGP code that requires changes to existing packages.

So late in the game now that I cannot see this going in for the 6.3 release. Flagging it for the future, but if anyone knows for sure that the current version works properly with *all* the BLFS packages that can use it, please mark it back (with your notes) to 6.3 and we'll update it.

comment:2 by Randy McMurchy, 13 years ago

Milestone: future6.4

comment:3 by willimm, 13 years ago

Appantly, there is a 2.6.2 avable. 2.6.0 worked fine for me.

comment:4 by jhuntwork@…, 13 years ago

Also note that the location of the sources has changed. See:

http://www.gnu.org/software/gnutls/releases/moved-to-gnu.org.txt

The 1.x versions don't seem to be available any longer.

comment:5 by jhuntwork@…, 13 years ago

Summary: GnuTLS-2.3.4GnuTLS-2.6.2

comment:6 by willimm, 13 years ago

New version, GnuTLS 2.6.3.

comment:7 by Ag. Hatzimanikas, 13 years ago

Summary: GnuTLS-2.6.2GnuTLS-2.6.3

Dependencies.

libtasn1

If not found it uses the internal version

http://redmine.josefsson.org/wiki/libtasn1/Libtasn1

guile for guile bindings

Also gaa (intended for developers)

From configure output

GAA was not found.  It is only needed if you wish to modify
*** the source code or command-line description files.  In this case,
*** you may want to get it from http://gaa.sourceforge.net/

Happy New Year.

comment:8 by Ag. Hatzimanikas, 13 years ago

Curl compiled and confirmed to work with gnutls-2.6.3.

When using curl for "https" you may want to provide a certifitate, using the "--cacert" command line option, see for details:

http://curl.haxx.se/docs/sslcerts.html

Also libssh2 (the library which culr is using for secure connections), can be compiled against libgcrypt instead of openssl, using the "--with-libgcrypt" configure switch,

comment:9 by Ag. Hatzimanikas, 13 years ago

Mutt compiled against gnutls-2.6.3 and confirmed to work.

As a side note, cyrus-sasl requires openssl and by checking the archives and the cvs repository I didn't found any sign of gnutls support.

comment:10 by Ag. Hatzimanikas, 13 years ago

Elinks (pending for inclussion, see #2797) compiled against 2.6.3 and confirmed to work.

comment:11 by Randy McMurchy, 12 years ago

Milestone: 6.46.5

Modified milestone from 6.4 to 6.5

comment:12 by Randy McMurchy, 12 years ago

Summary: GnuTLS-2.6.3GnuTLS-2.8.1

Version increment to 2.8.1

comment:13 by Wayne Blaszczyk, 12 years ago

Owner: changed from blfs-book@… to Wayne Blaszczyk
Status: newassigned

comment:14 by Wayne Blaszczyk, 12 years ago

Resolution: fixed
Status: assignedclosed

Updated to GnuTLS-2.8.4.

comment:15 by (none), 11 years ago

Milestone: 6.5

Milestone 6.5 deleted

Note: See TracTickets for help on using tickets.