Opened 14 years ago

Closed 12 years ago

Last modified 11 years ago

#2450 closed defect (invalid)

Proftp failure to compile

Reported by: Stefan Morrell Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: SVN
Severity: major Keywords:
Cc:

Description

LFS Built against Devel version.

GCC - 4.2.2 GLIBC - 2.7 BINUTILS - 2.18

cd lib/ && make lib make[1]: Entering directory `/sources/proftpd-1.3.1/lib' gcc -DHAVE_CONFIG_H -DLINUX -I.. -I../include -O2 -Wall -c pr_fnmatch.c In file included from /usr/include/asm/sigcontext.h:4,

from /usr/include/bits/sigcontext.h:28, from /usr/include/signal.h:333, from /usr/include/sys/wait.h:31, from ../include/conf.h:95, from pr_fnmatch.c:38:

/usr/include/asm/types.h:6: error: conflicting types for 'mode_t' /usr/include/sys/types.h:72: error: previous declaration of 'mode_t' was here make[1]: * [pr_fnmatch.o] Error 1 make[1]: Leaving directory `/sources/proftpd-1.3.1/lib' make: * [lib] Error 2

Same error in versions 1.3.0 & 1.3.1

Appears fixed in current CVS (1.3.2rc1)

Change History (9)

comment:1 by Stefan Morrell, 14 years ago

Sorry - allow me to make that somewhat readable... Please delete above non-formatted mess!

LFS Built against Devel version.

GCC - 4.2.2

GLIBC - 2.7

BINUTILS - 2.18

cd lib/ && make lib
make[1]: Entering directory `/sources/proftpd-1.3.1/lib'
gcc -DHAVE_CONFIG_H  -DLINUX  -I.. -I../include  -O2 -Wall -c pr_fnmatch.c
In file included from /usr/include/asm/sigcontext.h:4,
                 from /usr/include/bits/sigcontext.h:28,
                 from /usr/include/signal.h:333,
                 from /usr/include/sys/wait.h:31,
                 from ../include/conf.h:95,
                 from pr_fnmatch.c:38:
/usr/include/asm/types.h:6: error: conflicting types for 'mode_t'
/usr/include/sys/types.h:72: error: previous declaration of 'mode_t' was here
make[1]: *** [pr_fnmatch.o] Error 1
make[1]: Leaving directory `/sources/proftpd-1.3.1/lib'
make: *** [lib] Error 2

Same error in versions 1.3.0 & 1.3.1

Appears fixed in current CVS (1.3.2rc1)

comment:2 by Randy McMurchy, 14 years ago

Milestone: 6.3future
Priority: normallow

This bug is not relevant for BLFS-6.3. If you use an LFS-6.3 toolchain both the 1.3.0 and 1.3.1 will compile and install just fine. There's no doubt there's probably issues using more a more recent toolchain.

Leaving the bug open (changed priority and target). If there is an updated version (1.3.2), then this bug should be closed as the problem is fixed in upstream CVS.

comment:3 by Randy McMurchy, 13 years ago

Milestone: future6.4
Priority: lownormal

comment:4 by Randy McMurchy, 13 years ago

Priority: normalhigh
Severity: normalmajor

There's now a 1.3.2rc3 available released on 20 November 2008. By the time we're ready to cut a BLFS-6.4rc and the 1.3.2 has not been released, we'll have to use the candidate.

http://proftpd.org/

comment:5 by willimm, 13 years ago

Another rassing-frassing-ProFTPD-rc-release-grumble-mumble. This time it's rc4, a bugfix one.

comment:6 by willimm, 13 years ago

Finaly there is 1.3.2. But I'm still sticking with vsftpd.

comment:7 by Randy McMurchy, 12 years ago

Milestone: 6.46.5

Modified milestone from 6.4 to 6.5

comment:8 by Randy McMurchy, 12 years ago

Resolution: invalid
Status: newclosed

Version 1.3.3 compiles clean. Closing this ticket.

comment:9 by (none), 11 years ago

Milestone: 6.5

Milestone 6.5 deleted

Note: See TracTickets for help on using tickets.