Opened 14 years ago

Closed 14 years ago

#2492 closed task (fixed)

Tcl/Tk 8.4.18

Reported by: Ag. Hatzimanikas Owned by: Randy McMurchy
Priority: normal Milestone: 6.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Version increment to 8.4.18

There are some failures in both of test suites. Here is the summary of Tcl,

all.tcl:	Total	10932	Passed	9939	Skipped	937	Failed	56
Sourced 129 Test Files.
Files with failing tests: http.test httpold.test io.test socket.test unixInit.test

Also running the Tk test suite, under one of those tiled window managers, i.e., Ion, Awesome, dwm, wmii, the suite will exit. Switching to floating mode, tests are continuing to run.

As I don't have any prior experience with the tcl/tk test suites, I am not sure if those failures can consider so serious to prevent updating.

Change History (5)

comment:1 by Randy McMurchy, 14 years ago

This is wierd. When I was goofing around the other day I used both the -18 and -15 versions and when I ran the test suite in Tcl, only the http.test failed. It was the only one.

I'll check again, but if we can't even get consistent results on similar platforms (you're using an LFS-6.3 platform, right) then this spooks me.

I'll do the test again and report back.

comment:2 by Randy McMurchy, 14 years ago

Now I really don't know what to think. :-(

Tests ended at Wed Mar 26 14:40:53 CDT 2008 all.tcl: Total 10932 Passed 9995 Skipped 937 Failed 0 Sourced 129 Test Files. Number of tests skipped for each constraint:

2 95or98 4 dontCopyLinks 47 emptyTest 2 hasIsoLocale 24 knownBug 1 largefileSupport 25 localeRegexp 126 macOnly 1 macOrWin 2 memDebug 3 memory 1 needPST 148 nonPortable 5 notNetworkFilesystem 2 pc 413 pcOnly 1 testWinCPUID 1 testwinclock 21 testwordend 254 tip268 41 tip280 1 umask2 2 unixOnly && unthreaded 3 unknownFailure 22 wideIntegerUnparsed 19 win 16 winOnly 5 xdev

in reply to:  1 comment:3 by Ag. Hatzimanikas, 14 years ago

Replying to randy@linuxfromscratch.org:

I'll check again, but if we can't even get consistent results on similar platforms (you're using an LFS-6.3 platform, right) then this spooks me.

Same results with LFS-6.3 and with current SVN.

Upgrade?

Your results looks good, and maybe there is something unpredictable in my setup. I tried to run them under two different shells and as root, but no matter what, I am taking those failures, but it could be probably my fault.

comment:4 by Randy McMurchy, 14 years ago

Owner: changed from blfs-book@… to Randy McMurchy
Status: newassigned

I'll test this out several times to see if I can get consistant results in the test suite. If so I'll update, if not we'll punt.

comment:5 by Randy McMurchy, 14 years ago

Resolution: fixed
Status: assignedclosed

I could not reproduce any test failures after several attempts of unpacking, building and running the tests. There are failures in the Tk test, but we recommend that the tests are not run anyway.

Updated BLFS to tcl-8.4.18 and tk-8.4.18

Note: See TracTickets for help on using tickets.