Opened 13 years ago

Closed 12 years ago

Last modified 11 years ago

#2547 closed task (fixed)

rsync-3.0.7

Reported by: Randy McMurchy Owned by: Ag. Hatzimanikas
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Version increment to 3.0.3.

http://rsync.samba.org/

Change History (12)

comment:1 by Randy McMurchy, 13 years ago

Milestone: future6.4

comment:2 by ken@…, 13 years ago

Summary: rsync-3.0.3rsync-3.0.4

Version increment to 3.0.4

comment:3 by ken@…, 13 years ago

Owner: changed from blfs-book@… to ken@…
Status: newassigned

comment:4 by ken@…, 13 years ago

Summary: rsync-3.0.4rsync-3.0.5

I've seen one oddity on 3.0.4 - when a file was deleted during the backup, I got a status of '(code 23)' prefixed by IO error encountered -- skipping file deletion

Normally, I would expect code 24 in that case.Can't find any other errors in that output, at first I thought the status codes must have changed, but checking the man page shows 23 is still regarded as an error. Google finds a few similar code 23 reports, mostly in logs, and I didn't see any obviously useful responses to postings. All of these reports were for 3.0.4, apart from one for 3.0.2.

The samba bugzilla has a report of code 23 caused by a directory with 000 permissions, but that was accompanied by a recognisable error message, my output only had 'no such file or directory' messages.

Meanwhile, 3.0.5 is out. Testing (untarred a package, started the rsync from /home to an nfs mount, deleted the package after a couple of seconds) I got the error. Will log this on the samba bugzilla when my ID arrives.

comment:6 by ken@…, 13 years ago

Upstream think they've fixed this. Will test with the current snapshot while waiting for 3.0.6.

comment:7 by ken@…, 12 years ago

Summary: rsync-3.0.5rsync-3.0.6

3.0.6 was released while I was offline - the snapshot worked, so I'm hopeful that my testing of this release will be successful.

comment:8 by ken@…, 12 years ago

Owner: changed from ken@… to blfs-book@…
Status: assignednew

This version (3.0.6) seems fine, but if we're now targetting LFS-6.5 I don't have a suitable build system to confirm the time and more specifically the size (in my experience, build times are always a little variable), so I can't do it.

comment:9 by Randy McMurchy, 12 years ago

Milestone: 6.46.5

Modified milestone from 6.4 to 6.5

comment:10 by Ag. Hatzimanikas, 12 years ago

Owner: changed from blfs-book@… to Ag. Hatzimanikas
Status: newassigned
Summary: rsync-3.0.6rsync-3.0.7

Version increment to 3.0.7.

I can update the book, but I don't get that space (35M) that is currently in the book, even if I built all the documentation, so I am going to leave the estimated space as it is now. Please correct later.

comment:11 by Ag. Hatzimanikas, 12 years ago

Resolution: fixed
Status: assignedclosed

Updated to rsync-3.0.7 in r8182.

comment:12 by (none), 11 years ago

Milestone: 6.5

Milestone 6.5 deleted

Note: See TracTickets for help on using tickets.