Opened 12 years ago

Closed 10 years ago

Last modified 8 years ago

#2987 closed defect (fixed)

alsa-lib-1.0.23

Reported by: zoyd Owned by: blfs-book@…
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords: audio, alsa, mixer
Cc:

Description

Recently upgraded from 6.4 to 6.5 with the new alsa-lib-1.0.21. After which sound apps didn't work like they should.

Here's my hardware:

bash-4.0$ cat /proc/asound/cards

0 [SB ]: HDA-Intel - HDA ATI SB

HDA ATI SB at 0xfbbf4000 irq 16

1 [HDMI ]: HDA-Intel - HDA ATI HDMI

HDA ATI HDMI at 0xfbde8000 irq 19

One issue that lead to a solution was the error mpd returned when launching "ALSA lib conf.c:4626:(snd_config_expand) Expand error (walk): File exists"

Also alsamixer failed to show a PCM 'device'.

None of the above problem happened with 6.4 running alsa-lib-1.0.18.

It seems others have had similar problems: https://bugzilla.redhat.com/show_bug.cgi?id=521988 http://bbs.archlinux.org/viewtopic.php?pid=616738

Reporting is as alsa-lib-1.0.21 being broken and requesting BLFS to upgrade to 1.0.21a.

Link: http://www.alsa-project.org/main/index.php/Changes_v1.0.21_v1.0.21a

Change History (8)

comment:1 by Guy Dalziel, 12 years ago

Are you sure that the problem is alsa? There have been quite a few problems with HDA-Intel lately in the kernel, most notably with realtek chipsets. I was only able to get my sound working after upgrading to 2.6.31. I do remember the PCM channel missing, but I don't recall actually needing it to turn the volume up. The PCM channel does show up after I restore my stored values, but turning it down to 0 has no effect upon the volume.

comment:2 by zoyd, 12 years ago

Sound does work in alsa-lib-1.0.21 and so does the volume, atleast in alsamixer. The problem is that apps expect to find a PCM for the mixer, which is missing in alsa-lib-1.0.21, hence alsa-lib-1.0.21a.

This may be a minor issue considering the status of BLFS currently and it won't hurt to wait for the next alsa-lib release, including tools/firmware/utils/etc.

The problem is in alsa for sure.

comment:3 by zoyd-lfs, 11 years ago

Please upgrade to alsa 1.0.23

http://www.alsa-project.org/ http://www.alsa-project.org/main/index.php/Download

close this bug after upgrade

comment:4 by (none), 11 years ago

Milestone: 6.5

Milestone 6.5 deleted

comment:5 by Randy McMurchy, 11 years ago

Milestone: 6.7

Updated milestone to 6.7

comment:6 by ken@…, 10 years ago

Summary: alsa-lib-1.0.21alsa-lib-1.0.23

Changed title to match requested version.

comment:7 by bdubbs@…, 10 years ago

Resolution: fixed
Status: newclosed

Upgraded to alsa-1.0.24.1

comment:8 by bdubbs@…, 8 years ago

Milestone: 6.7

Milestone 6.7 deleted

Note: See TracTickets for help on using tickets.