Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#3446 closed defect (fixed)

GDM/Gnome will not start with D-Bus 1.6.0

Reported by: Wayne Blaszczyk Owned by: Armin K
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

On a fresh build, GDM will not start when D-Bus 1.6.0 is installed. The following error is produced when starting dbus:

Failed to open "/etc/machine-id": No such file or directory However dbus-daemon does start. I suspect this is something to do with not having systemd installed.

The following error from :0-greeter.log :

D-Bus library appears to be incorrectly set up; failed to read machine uuid: Failed to open "/etc/machine-id": No such file or directory

Installing D-Bus 1.4.20 and then re-installing D-Bus 1.6.0 fixes the problem.

Change History (4)

comment:1 by Armin K, 10 years ago

Hm, this might be related to this bug

https://bugs.freedesktop.org/show_bug.cgi?id=51406

machine-id should be located in /var/lib/dbus on non-systemd builds, but /var/lib/dbus isn't created by make install. Can you confirm this? Just rm -rf that dir, re-create it and run dbus-uuidgen --ensure to make sure it works. D-Bus init script should've printed a warning or whatever about that being non-sucessfull.

comment:2 by Armin K, 10 years ago

Owner: changed from blfs-book@… to Armin K
Status: newassigned

Confirmed. On D-Bus 1.6.0 /var/lib/dbus dir isn't installed and D-Bus will attempt to read machine-id from /etc which systemd generates. But if you are not using systemd, no machine-id will be in /etc, and since there is no /var/lib/dbus, it won't get generated in there by running dbus-uuidgen --ensure. D-Bus 1.6.2 has the issue fixed. I'll commit it today.

comment:3 by Armin K, 10 years ago

Resolution: fixed
Status: assignedclosed

I've commited D-Bus 1.6.2 upgrade and problem does not seem to persist with that version. Fixed in r10378

comment:4 by bdubbs@…, 8 years ago

Milestone: current

Milestone current deleted

Note: See TracTickets for help on using tickets.