Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4164 closed enhancement (fixed)

dbus-1.6.16

Reported by: bdubbs@… Owned by: Fernando de Oliveira
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New Point version

Change History (8)

comment:1 by Fernando de Oliveira, 8 years ago

I am trying to update this. Builds and works fine. However, test fails to even configure:

configure: Full test coverage was requested with --enable-tests=yes
configure: This has many dependencies (GLib, dbus-glib, Python)
checking for GLIB... yes
checking for DBUS_GLIB... yes
configure: Full test coverage (--enable-tests=yes) requires Python, dbus-python, pygobject
checking for a Python interpreter with version >= 2.6... python
checking for python... /usr/bin/python
checking for python version... 2.7
checking for python platform... linux2
checking for python script directory... ${prefix}/lib/python2.7/site-packages
checking for python extension module directory... ${exec_prefix}/lib/python2.7/site-packages
checking for Python modules for full test coverage... Traceback (most recent call last):
  File "<string>", line 1, in <module>
ImportError: No module named dbus
no
configure: error: cannot import dbus, gobject, dbus.mainloop.glib Python modules

I see that there are some restrictions to the tests, so wanted to report the failure, before proceeding. Tried to include --prefix=/usr in the configure for the tests, but obtained similar error.

Last edited 8 years ago by Fernando de Oliveira (previous) (diff)

comment:2 by Fernando de Oliveira, 8 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

comment:3 by Fernando de Oliveira, 8 years ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 11974.

Instructions for running the tests modified. Could not find how to solve everything. After trial and error, found that probably all tests but one seem to be running with the modified instructions.

If someone finds better solution, please edit the page and accept my apologies.

comment:4 by Fernando de Oliveira, 8 years ago

Resolution: fixed
Status: closedreopened

I was thinking more, about this, and found DBus Python 1.2.0. Perhaps this will solve the tests issue.

Before further investigating, I need to clarify what I wrote before. There are four switches for the tests:

  --enable-embedded-tests enable unit test code in the library and binaries
  --enable-modular-tests  enable modular regression tests (requires GLib)
  --enable-tests          enable/disable all tests, overriding
                          embedded-tests/modular-tests
  --enable-installed-tests

Could not use --enable-tests, due to the failure I reported before.

When used the other switches, one by one, it seemed that --enable-embedded-tests covered the other remaining two.

Have not tested with all three but --enable-tests (forgot, sorry).

Fires, I will install DBus Python 1.2.0 and see if the tests can be run using only --enable-tests.

If not, will try the other three at once, to see if what I said before holds true, about using only --enable-embedded-tests.

comment:5 by Fernando de Oliveira, 8 years ago

OK. One test still needs to be disabled (fails):

sed -i -e 's:run-test.sh:$(NULL):g' test/name-test/Makefile.in

Apparently, the end result is the same as I got before, with the updated instructions for 1.6.16 (--enable-embedded-tests).

Even if someone finds a better a solution for the failed test, there are two alternatives:

  1. Leave as I updated.
  1. Revert to --enable-tests switch, but replace Python-2.7.5 by dbus-python-1.2.0 in "Optional ... (to run the tests)".

comment:6 by Fernando de Oliveira, 8 years ago

There is a discussion at

http://permalink.gmane.org/gmane.linux.lfs.beyond.support/44782

I it possible that there is a relationship with present test issue?

Also have seen this:

https://bugs.freedesktop.org/show_bug.cgi?id=57140

comment:7 by Fernando de Oliveira, 8 years ago

Resolution: fixed
Status: reopenedclosed

Fixed at 11978.

comment:8 by bdubbs@…, 8 years ago

Milestone: current

Milestone current deleted

Note: See TracTickets for help on using tickets.