Opened 20 years ago

Closed 18 years ago

Last modified 13 years ago

#43 closed defect (fixed)

XFree86-4.3.0

Reported by: markh@… Owned by: bdubbs@…
Priority: normal Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc:

Description

Change History (12)

comment:1 by markh@…, 20 years ago

Summary: X-4.10X-4.2

note that there's a test host.def file available at:

http://www.linuxfromscratch.org/~markh/blfs/beta/host.def-0.1a

could people test it out so I know it works before I start writing it all up.

comment:2 by markh@…, 19 years ago

Milestone: 1.0

comment:3 by bdubbs@…, 19 years ago

Owner: changed from blfs-book@… to bdubbs@…

comment:4 by markh@…, 19 years ago

Bruce, before you start this (hopefully), I should point out this file: http://www.linuxfromscratch.org/~markh/blfs/beta/host.def-0.1a This is a pretty full featured X config file (goes in xc/config/host.def IIRC) which was designed for X-4.10 but shouldn't need any modification for X-4.2 (I hope). Chris and Jeremy spent ages going through digging out all the options which are available. Hope this is useful

comment:5 by bdubbs@…, 19 years ago

Status: newassigned

comment:6 by bdubbs@…, 19 years ago

Resolution: fixed
Status: assignedclosed

There are still a few issues with the XFree86 instructions, but I'm changing the resolution to Fixed until there is some feedback.

comment:7 by bdubbs@…, 19 years ago

Resolution: fixed
Status: closedreopened

From Skip Gaede: I am building X on a Nubus-Pmac (ppc 601). The CFLAGS argument in the book (-O2 -mcpu=601) caused the makekeys executable to segfault. I commented out the

#define DefaultGcc2PpcOpt -O2 -mcpu=601

line and now it's building fine. You might want to make note of that in the book.

comment:8 by bdubbs@…, 19 years ago

Resolution: fixed
Status: reopenedclosed

Added comments about Power PC. Fixed typos.

comment:9 by highos@…, 19 years ago

Summary: X-4.2XFree86-4.2.1

Version increment, looks like Bruce forget to update bugzilla (no biggie :)

comment:10 by highos@…, 19 years ago

Resolution: fixed
Status: closedreopened
Summary: XFree86-4.2.1XFree86-4.3.0

Version increment (4.3.0)

comment:11 by tushar@…, 18 years ago

Resolution: fixed
Status: reopenedclosed

comment:12 by (none), 13 years ago

Milestone: 1.0

Milestone 1.0 deleted

Note: See TracTickets for help on using tickets.