Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#4479 closed defect (fixed)

lxde-common requires lsb_release as a runtime dependency

Reported by: WilliamImm Owned by: Fernando de Oliveira
Priority: high Milestone:
Component: BOOK Version: SVN
Severity: major Keywords:
Cc:

Description

Without the lsb_release program, lxde-logout will crash when you try to run it (meaning, you can't log out out of an LXDE session). Installing lsb_release as per the book will let lxde-logout bring up the logout window, as expected.

And before you ask, yes, I have no idea why the lxde-logout program depends specifically on lsb_release. Just that it does.

Change History (6)

comment:1 by WilliamImm, 9 years ago

Actually, it's lxsession that requires lsb_common for some reason. lxde-logout is just a wrapper script. Also, I manged to figure out why lxsession requires lsb_common: to get the distro version. So, question solved.

Last edited 9 years ago by WilliamImm (previous) (diff)

comment:2 by Fernando de Oliveira, 9 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

Had to see with my eyes, to believe. Thanks.

comment:3 by Fernando de Oliveira, 9 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r12449.

comment:4 by WilliamImm, 9 years ago

I'm not the same person as William Harrington on the mailing lists, by the way. My last name starts with an I, not a H. Just as there isn't a One Steve Limit, there isn't a One William Limit.

comment:5 by Fernando de Oliveira, 9 years ago

Sorry about that, William I. That was a nice reading. I will try to fix where I can.

s/H/I/ at r12460.

comment:6 by bdubbs@…, 9 years ago

Milestone: current

Milestone current deleted

Note: See TracTickets for help on using tickets.