Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4598 closed enhancement (fixed)

cogl-1.16.2

Reported by: Fernando de Oliveira Owned by: Fernando de Oliveira
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Attachments (1)

cogl-1.16.2-make-k-check-LXDE-2014.01.21-12h41m41s.log (12.3 KB ) - added by Fernando de Oliveira 8 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 by Fernando de Oliveira, 8 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

by Fernando de Oliveira, 8 years ago

comment:2 by Fernando de Oliveira, 8 years ago

Tests need to be run in X, apparently.

All tests fail from ssh.

All tests fail something called GL3, GL 3 driver, which was included at 1 Oct 2012 13:07:13 +0000 (UTC).

Tests log attached.

https://mail.gnome.org/archives/commits-list/2012-October/msg00118.html

After all this day, I am leaning to unrecommend the tests.

If somebody have any idea, please tell me. Thanks.

It is ready for update. I will prepare a couple more, before committing all that got prepared, later, today.

comment:3 by Fernando de Oliveira, 8 years ago

Better explaining:

From ssh, everything in all tests is marked FAIL

From X, few tests completely fail, all fail GL3.

comment:4 by Armin K, 8 years ago

First of all, you should NEVER run tests via ssh. Test should be ran from a local session.

Second, any library depending on Mesa (libGL, libGLESv2, libEGL) require working DRI installation at runtime (and running tests = runtime) and that means that X server should be running locally with DRI2 enabled and at least OGL 3.0 for all tests to pass. Check glxinfo output for OpenGL version string or see an example on the Xorg Configuration page. It worked fine on my sandybridge system when I tried it last time.

Third, but not related. I believe that running tests is a waste of time. They are not called "regression tests" without a reason. It could mean it's there for developer to check if he/she broke something with some new changes. Just take GCC test suite for example, for every fix there's a regression test so that DEVELOPER can't introduce the bug AGAIN. If you break something as an user, you'll know soon enough :)

Last edited 8 years ago by Armin K (previous) (diff)

in reply to:  4 comment:5 by Fernando de Oliveira, 8 years ago

Replying to Krejzi:

First of all, you should NEVER run tests via ssh. Test should be ran from a local session.

I did not know, that. Most tests I run pass, using ssh. Today, they dis for wget. Why is it?

Second, any library depending on Mesa (libGL, libGLESv2, libEGL) require working DRI installation at runtime (and running tests = runtime) and that means that X server should be running locally with DRI2 enabled and at least OGL 3.0 for all tests to pass. Check glxinfo output for OpenGL version string or see an example on the Xorg Configuration page. It worked fine on my sandybridge system when I tried it last time.

It is the first thing I do, when I finish xorg or reinstall mesa:

$ glxinfo | egrep "(OpenGL vendor|OpenGL renderer|OpenGL version)"
OpenGL vendor string: VMware, Inc.
OpenGL renderer string: Gallium 0.4 on SVGA3D; build: RELEASE;  
OpenGL version string: 2.1 Mesa 10.0.1

Could it be a problem there?

Third, but not related. I believe that running tests is a waste of time. They are not called "regression tests" without a reason. It could mean it's there for developer to check if he/she broke something with some new changes. Just take GCC test suite for example, for every fix there's a regression test so that DEVELOPER can't introduce the bug AGAIN. If you break something as an user, you'll know soon enough :)

Right. I reached similar conclusions years ago, and stopped to run tests. Now, I do only for the book, because this is what is there.

I did upgrade my vmplayer, but not the vmtools. The machine was not working fine,

But Bruce and, I think, others, think the tests should be run. Furthermore, either we get the test instructions off of the book, or try to make them work as we can, or tell that the do not run. I don't think we can just ignore, without a discussion.

Personally, I hate tests.

comment:6 by Fernando de Oliveira, 8 years ago

Forgot: if the tests are not perfect, I enter the machine and try again. If they are perfect at ssh, I do not bother anymore.

comment:7 by Armin K, 8 years ago

OpenGL version string: 2.1

This says that OpenGL version supported by vmwgfx (svga3d) is 2.1, but for GL3 tests to pass you need at least (doh) OpenGL 3.0 - should be obvious.

As for ssh, you can achieve very different results from running tests from SSH. Especially for apps that use D-Bus, X11 apps (with or without forwarding) and as you have seen, GL apps.

For basic apps such as LFS, most of the apps that don't use any of the mentioned above tests should do fine, but still may produce some unexpected results.

Also, the tests are not just a waste of users' time, but a waste of developers' time too. I've seen you struggle to get some testsuite working and for the time it took you to do that you could've done more useful work. For apps that few tests failed in the past, I was happy to report that few tests fail (or not mention them at all) or for apps that lot of tests fail I simply pointed out that test suite wasn't working at all.

Furthermore, desktop apps' test suites are horrible and require lot of stuff working together - OpenGL (some only) X11 and properly registered D-Bus session - with ConsoleKit, system dbus-daemon and such.

comment:8 by Fernando de Oliveira, 8 years ago

OK. Thanks. I will leave the the tests as is (are). I still have so much to learn. This time, what you wrote, in the hurry I am, was not understood in my diagonal reading: OGL meaning OpenGL (doh, really).

I hate tests. But I have had some fun when I learned something. Like now.

Of course, doing or not tests in the book might be a good discussion. And I tend to agree with you and Igor, about them.

comment:9 by Fernando de Oliveira, 8 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r12616.

comment:10 by bdubbs@…, 8 years ago

Tests are important for us to make sure we didn't do anything wrong with switches, dependencies, etc.

I really dislike GL3. It means we can't run the app over ssh. That, to me, means the app is broken by design.

comment:11 by Armin K, 8 years ago

Running a testsuite doesn't really say a thing about package being broken or not.

a) All tests could pass but you could still hit a code path where app/library would segfault (for me all gcc tests passed but compiler still segfaulted on rare occassions, glibc tests passed but still some runtime errors - see glibc reverted change).

b) No test could pass, but app/library could still work flawlessly (like this one and many countless others).

As for the broken design, do you want to say that entire Linux OpenGL stack is broken by design?

comment:12 by bdubbs@…, 8 years ago

Milestone: current

Milestone current deleted

Note: See TracTickets for help on using tickets.