Opened 8 years ago

Closed 8 years ago

Last modified 8 years ago

#4670 closed defect (fixed)

IcedTea-Web-1.4.2 does not compile against Xulrunner-27

Reported by: Merell L. Matlock, Jr. Owned by: Fernando de Oliveira
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

(B)LFS-7.4 (except for minor updates from BLFS-SVN. Built and installed Xulrunner/Firefox 27. Attempted to update IcedTea-Web from V4.1 (built against Xulrunner 23.0.1). OpenJDK-1.7.0.51/IcedTea-2.4.5 is installed.

Make output:

In file included from /sources/blfs/build/icedtea-web-1.4.2/plugin/icedteanp/IcedTeaScriptablePluginObject.h:43:0,
                 from /sources/blfs/build/icedtea-web-1.4.2/plugin/icedteanp/IcedTeaScriptablePluginObject.cc:41:
/sources/blfs/build/icedtea-web-1.4.2/plugin/icedteanp/IcedTeaScriptablePluginObject.cc: In static member function 'static bool IcedTeaScriptableJavaObject::getProperty(NPObject*, NPIdentifier, NPVariant*)':
/usr/include/xulrunner-27.0/npruntime.h:140:30: error: 'nullptr' was not declared in this scope
     (_v).value.objectValue = nullptr;                                         \
                              ^
/sources/blfs/build/icedtea-web-1.4.2/plugin/icedteanp/IcedTeaScriptablePluginObject.cc:688:17: note: in expansion of macro 'VOID_TO_NPVARIANT'
                 VOID_TO_NPVARIANT(*result);
                 ^
make: *** [/sources/blfs/build/icedtea-web-1.4.2/plugin/icedteanp/IcedTeaScriptablePluginObject.o] Error 1

There is no difference between /usr/lib/xulrunner-devel-23.0.1/include/npruntime.h and /usr/lib/xulrunner-devel-26.0/include/npruntime.h.

However:

merell [ ~ ]$ diff -n /usr/lib/xulrunner-devel-26.0/include/npruntime.h /usr/lib/xulrunner-devel-27.0/include/npruntime.h               
d140 1
a140 1
    (_v).value.objectValue = nullptr;                                         \
d146 1
a146 1
    (_v).value.objectValue = nullptr;                                         \
d219 1
a219 1
    NPIdentifier(s) will be nullptr. NPIdentifier lifetime is controlled
d286 3
a288 3
    will typically return immediately, with 0 or nullptr, from an
    attempt to dispatch to a NPObject, but this behavior should not
    be depended upon.)

Change History (6)

comment:1 by Merell L. Matlock, Jr., 8 years ago

Better diff:

merell [ ~ ]$ diff /usr/lib/xulrunner-devel-26.0/include/npruntime.h /usr/lib/xulrunner-devel-27.0/include/npruntime.h
140c140
<     (_v).value.objectValue = NULL;                                            \
---
>     (_v).value.objectValue = nullptr;                                         \
146c146
<     (_v).value.objectValue = NULL;                                            \
---
>     (_v).value.objectValue = nullptr;                                         \
219c219
<     NPIdentifier(s) will be NULL. NPIdentifier lifetime is controlled
---
>     NPIdentifier(s) will be nullptr. NPIdentifier lifetime is controlled
286,288c286,288
<     will typically return immediately, with 0 or NULL, from an attempt
<     to dispatch to a NPObject, but this behavior should not be
<     depended upon.)
---
>     will typically return immediately, with 0 or nullptr, from an
>     attempt to dispatch to a NPObject, but this behavior should not
>     be depended upon.)

comment:2 by Fernando de Oliveira, 8 years ago

I cannot confirm .

I updated ITW (February 6th, 2014) using Xulrunner 27 (February 4th, 2014) without a problem.

However, I had a similar problem with an older box, where I needed to update some packages, to get Xulrunner 27.If the error is the same, I may be able to help.

I would like to see the log since the previous g++ instruction (very big instruction) leading to the error, until the part you sent before.

Please, send not here, but to the support list.

comment:3 by Fernando de Oliveira, 8 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

Confirmed.

It seems that NPAPI-SDK-0.27.2 is missing as required for IcedTea-Web. I did not notice in 7.4, because I already had it installed. LibreOffice and Gnash were updated, but not IcedTea-Web. It seems that the support was introduced in IcedTea-Web 1.2:

http://icedtea.classpath.org/wiki/IcedTea-Web

Waiting for Merell to report back, and then, to fix the book.

in reply to:  3 comment:4 by Merell L. Matlock, Jr., 8 years ago

Replying to fo:

Confirmed.

It seems that NPAPI-SDK-0.27.2 is missing as required for IcedTea-Web. I did not notice in 7.4, because I already had it installed. LibreOffice and Gnash were updated, but not IcedTea-Web. It seems that the support was introduced in IcedTea-Web 1.2:

http://icedtea.classpath.org/wiki/IcedTea-Web

Waiting for Merell to report back, and then, to fix the book.

Installed NPAPI-SDK-0.27.2--IcedTea-Web built and installed successfully. I'll report same on BLFS-support.

Thank you!

Merell Matlock

comment:5 by Fernando de Oliveira, 8 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r12682.

Thanks for reporting.

comment:6 by bdubbs@…, 8 years ago

Milestone: current

Milestone current deleted

Note: See TracTickets for help on using tickets.