Opened 7 years ago

Closed 7 years ago

#5297 closed enhancement (fixed)

LVM2.2.02.108

Reported by: Fernando de Oliveira Owned by: Fernando de Oliveira
Priority: normal Milestone: 7.6
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Change History (3)

comment:1 by Fernando de Oliveira, 7 years ago

https://git.fedorahosted.org/cgit/lvm2.git/plain/WHATS_NEW

Version 2.02.108 - 23rd July 2014
=================================
  Add lvscan --cache which re-scans constituents of a particular LV.
  Make dmeventd's RAID plugin re-scan failed PVs when lvmetad is in use.
  Improve code sharing for lvconvert and lvcreate and pools (cache & thin).
  Improve lvconvert --merge validation.
  Improve lvconvert --splitsnapshot validation.
  Add report/list_item_separator lvm.conf option.
  Add lv_active_{locally,remotely,exclusively} LV reporting fields.
  Comment out devices/{preferred_names,filter} in default lvm.conf file.
  Enhance lvconvert thin, thinpool, cache and cachepool command line support.
  Display 'C' only for cache and cache-pool target types in lvs.
  Prompt for confirmation before change LV into a snapshot exception store.
  Return proper error codes for some failing lvconvert funtions.
  Add initial code to use cache tools (cache_check|dump|repair|restore).
  Support lvdisplay --maps for raid.
  Add --activationmode degraded to activate degraded raid volumes by default.
  Add separate lv_active_{locally,remotely,exclusively} LV reporting fields.
  Recognize "auto"/"unmanaged" values in selection for appropriate fields only.
  Add report/binary_values_as_numeric lvm.conf option for binary values as 0/1.
  Add --binary arg to pvs,vgs,lvs and {pv,vg,lv}display -C for 0/1 on reports.
  Add separate reporting fields for each each {pv,vg,lv}_attr bit.
  Separate LV device status reporting fields out of LV fields.
  Fix regression causing PVs not in VGs to be marked as allocatable (2.02.59).
  Fix VG component of lvid in vgsplit/vgmerge and check in vg_validate.
  Add lv_full_name, lv_parent and lv_dm_path fields to reports.
  Change lv_path field to suppress devices that never appear in /dev/vg.
  Postpone thin pool lvconvert prompts (2.02.107).
  Require --yes option to skip prompt to lvconvert thin pool chunksize.
  Support lvremove -ff to remove thin volumes from broken thin pools.
  Require --yes to skip raid repair prompt.
  Change makefile %.d generation to handle filename changes without make clean.
  Fix use of buildir in make pofile.
  Enhance private volumes UUIDs with suffixed for easier detection.
  Do not use reserved _[tc]meta volumes for temporary LVs.
  Leave backup pool metadata with _meta%d suffix instead of reserved _tmeta%d.
  Allow RAID repair to reuse PVs from same image that suffered a failure.
  New RAID images now avoid allocation on any PVs in the same parent RAID LV.
  Always reevaluate filters just before creating PV.

comment:2 by Fernando de Oliveira, 7 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

comment:3 by Fernando de Oliveira, 7 years ago

Resolution: fixed
Status: assignedclosed

I think I wrote before, but just to be sure: this is one package that I do the tests, but have some errors, because either kernel or system do not have all conditions to run them. Please, if anybody wants to modify the tests statistics or words, do not hesitate, after the updates.

Fixed at r13698.

Note: See TracTickets for help on using tickets.