Opened 8 years ago

Closed 8 years ago

#5336 closed defect (fixed)

OpenJDK-1.7.0.65/IcedTea-2.5.1 fails on configure

Reported by: christopher Owned by: Pierre Labastie
Priority: normal Milestone: 7.6
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

When building IcedTea from source code using the latest svn instructions configure fails because it cannot find fastjar in the path.

I do not remember this being a requirement in the past, and can not even find fastjar on my previous gnome-build.

The download link that I found is:

http://sourceforge.net/projects/fastjar/

The download link that John Burrell found for a later version, and untested by me is:

http://gnu.mirrors.pair.com/savannah/savannah/fastjar/

Could someone else please verify this new requirement and update TRUNK appropriately?

It is defined in configure.ac as:

IT_FIND_TOOLS([FASTJAR], [fastjar jar])

Checking my icedtea 4.7.1 configure.ac it has:

AC_CHECK_TOOLS([FASTJAR], [fastjar jar]) if test "x$FASTJAR" = x; then

AC_MSG_ERROR([Can't find fastjar or jar])

So it looks to me that it is now a requirement

Change History (7)

comment:1 by christopher, 8 years ago

Summary: Iced Tea fails configureOpenJDK-1.7.0.65/IcedTea-2.5.1 fails on configure

comment:2 by Fernando de Oliveira, 8 years ago

This is waiting for Pierre who is not available at the moment.

comment:3 by Armin K, 8 years ago

I cannot confirm the issue.

The snippet from configure you presented here tells you that it's looking for either fastjar or jar programs. The latter is installed by OpenJDK binary installation, and the build finished without any issues.

comment:4 by Pierre Labastie, 8 years ago

When I updated Icedtea to the last version, I did not have fastjar installed and it built fine. I remember seeing that error in the past, though, but I cannot remember when. Maybe while trying to build directly from gcj...

It may be a path problem, though. What does happen if you just type

jar

in reply to:  4 ; comment:5 by christopher, 8 years ago

Replying to pierre.labastie:

When I updated Icedtea to the last version, I did not have fastjar installed and it built fine. I remember seeing that error in the past, though, but I cannot remember when. Maybe while trying to build directly from gcj...

It may be a path problem, though. What does happen if you just type

jar

Hello Pierre,

I am putting this down to a quirk on my computers part. Its the only way to describe it. I was following the instructions through with the page up and again came up against this error. Even though I had issued these instructions on the binary jdk page:

export PATH="$PATH:/opt/OpenJDK-1.7.0.65-bin/bin"

And following through to the Junit, Apacheant, and finally to OpenJDK-1.7.0.65/IcedTea-2.5.1 some how or other my computer LOST the frigging path. I had to do:

pathappend $JAVA_HOME/bin PATH

This is really crazy having to do it twice.

Fast jar is not needed, however it seems that by me installing it last time it actually corrected the path.

I now have to make sure that I tripple check the path. I know that I had entered it correctly.

At first I tried it within a script, but as the scripts enter a sub-shell once it has run it is not in the current shell's environment. I double checked in the script and the path was put in there correctly.

So until I get a new computer I will have to keep an eye on it.

I am glad that I have finally nailed the cause though.

Regards,

Christopher.

comment:6 by Pierre Labastie, 8 years ago

Owner: changed from blfs-book@… to Pierre Labastie
Status: newassigned

It seems that the envars setting for building OpenJDK is not made clear enough in the book, since it is not the first time that somebody hits a problem. I'll edit (again) the icedtea page to make it clearer, before colsing this ticket.

in reply to:  5 comment:7 by Pierre Labastie, 8 years ago

Resolution: fixed
Status: assignedclosed

Added a note about the environment at r14094, which hopefully makes things clearer.

Note: See TracTickets for help on using tickets.