Opened 9 years ago

Closed 8 years ago

#5926 closed defect (fixed)

xindy from texlive-from-source does not work on i?86.

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 7.7
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Noticed this on Friday when running my regression tests on 32-bit. I've now built it on 7.6 and that has the same problem.

Works fine on x86_64.

Change History (8)

comment:1 by ken@…, 8 years ago

Owner: changed from blfs-book@… to ken@…

Cannot work out for the life of me what is wrong - my test uses makeglossaries _without_ glossaries. If I produce the glossaries, those work ( on another distro that gave me useful error messages ), but the indexes themselves still fail to appear on i686.

In view of the aggravation involved in building texlive twice to get xindy (and asymptote) I'm intending to move to a separate build of xindy. But for the moment, it looks as if it will get a big "Note: does not work on i686, please help if you can debug this" message.

comment:2 by ken@…, 8 years ago

Status: newassigned

comment:3 by ken@…, 8 years ago

Partially addressed (I've added a note to the new separate page) in r15327.

comment:4 by ken@…, 8 years ago

Owner: changed from ken@… to blfs-book@…
Status: assignednew

Passing back to blfs-book, I cannot work out what is broken.

comment:5 by ken@…, 8 years ago

Progress: it appears to work if built in the C (or POSIX) locale - my user lives in a UTF-8 locale, and that caused xindy's latin.xdy file to contain a header, a blank line, and then (only)

Binary file (standard input) matches

after it had been through 'sort -u', instead of a lot of lines containing clisp commands in parentheses : no idea what was different between my old (two-pass texlive) builds on x86_64 and (in a VM) i686, but it turns out not to be a 32/64 issue. And with separate xindy the problem now shows in my x86_64 - I suppose I must have used LC_ALL=C when doing a non-scripted test.

The book needs to be changed to tell people to build this in the C or POSIX locale.

comment:6 by ken@…, 8 years ago

Owner: changed from blfs-book@… to ken@…
Status: newassigned

comment:7 by ken@…, 8 years ago

Fixed at r15397.

comment:8 by bdubbs@…, 8 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.