Opened 7 years ago

Closed 7 years ago

#6142 closed enhancement (fixed)

MesaLib-10.5.1

Reported by: Fernando de Oliveira Owned by: Pierre Labastie
Priority: normal Milestone: 7.8
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

http://lists.freedesktop.org/archives/mesa-dev/2015-February/076783.html

Mesa 10.5.0 release candidate 1 is now available for testing. The
current plan is to have an additional release candidate every Friday
until the eventual 10.5.0 release on Mar 6th.
...
The expectation is that the 10.4 branch will remain alive with bi-weekly
releases until after 10.5.1 release.

Change History (15)

comment:1 by Pierre Labastie, 7 years ago

Summary: MesaLib-10.5.1 (placeholder)MesaLib-10.5.0 (placeholder)

Changing the version in the Summary, expecting that the daily script will be made silent.

Last edited 7 years ago by Pierre Labastie (previous) (diff)

comment:2 by Fernando de Oliveira, 7 years ago

I didn't understand this. It was 10.5.1 because this this is what we are waiting (the stable one). It won't make any difference for the daily script.

Perhaps you prefer the title version and the currency script have the same version.

Notice that under

ftp://ftp.freedesktop.org/pub/mesa/10.5.0/

we have mesa-10.5.0-rc1.tar.gz.

comment:3 by Fernando de Oliveira, 7 years ago

Forgot to write that whatever you want I am OK with it.

comment:4 by Pierre Labastie, 7 years ago

It is not what I want, Fernando, but what upstream wrote:

Mesa 10.5.0 release candidate 1 is now available for testing

This means that the next version to come is 10.5.0. And that they make available the first release candidate (-rc1) on their repos. And actually this is confirmed by the end of the sentence:

until the eventual 10.5.0 release on Mar 6th.

10.5.0 will appear on March 6th, not 10.5.1.

Now I agree that I have not idea how the currency scripts work, so that the summary change might not be enough to change the script behaviour.

comment:5 by Fernando de Oliveira, 7 years ago

Thanks, Pierre.

Well, may be ypu are right. But I have from memory seen the .0 as development. That is the reason I opened the ticket that way. From my time here, only once one editor wanted really include the development .0 in the book.

But I don't mind if you want to keep the ticket that way or even if you want to include a dev Mesa in the book.

http://www.mesa3d.org/

December 14, 2014

Mesa 10.4 is released. This is a new development release. See the
release notes for more information about the release.

September 19, 2014

Mesa 10.3 is released. This is a new development release. See the
release notes for more information about the release.

June 6, 2014

Mesa 10.2 is released. This is a new development release. See the
release notes for more information about the release.

March 4, 2014

Mesa 10.1 is released. This is a new development release. See the
release notes for more information about the release.

November 30, 2013

Mesa 10.0 is released. This is a new development release. See the
release notes for more information about the release.

August 27, 2013

Mesa 9.2 is released. This is a new development release. See the release
notes for more information about the release.

comment:6 by Pierre Labastie, 7 years ago

Thanks Fernando: I learned something today.

OTOH, I think there are many places where upstream makes no differences between development and release. For example, with gcc, the .0 version is usually rather buggy, and I think that for stability, it'd be better to wait for the first bugfix release (well, this will change with gcc-5).

And I am completely out of my tracks with the currency script! this ticket is reported by it, which is what should be.

comment:7 by Pierre Labastie, 7 years ago

Summary: MesaLib-10.5.0 (placeholder)MesaLib-10.5.1 (placeholder)

Changing the summary again, sorry for the noise.

in reply to:  4 comment:8 by bdubbs@…, 7 years ago

Replying to pierre.labastie:

Now I agree that I have not idea how the currency scripts work, so that the summary change might not be enough to change the script behaviour.

The currency script gets the base name, in this case MesaLib, and looks for that string in the title of the tickets. If found, it just uses that ticket number.

comment:9 by bdubbs@…, 7 years ago

Pierre, are you doing an update to MesaLib 10.4.5? I am there now and can do it tonight if you are not ready yet.

comment:10 by Pierre Labastie, 7 years ago

I am there too. I guess "tonight" for you was "very early morning" for me, so you have done it...

comment:11 by Fernando de Oliveira, 7 years ago

Bruce, I took the liberty of including an entry in the Change Log at r15548, documenting the update to MesaLib 10.4.5, that you did in r15545. Hope you don't mind.

comment:12 by bdubbs@…, 7 years ago

No, I don't mind. Thanks.

Last edited 7 years ago by bdubbs@… (previous) (diff)

comment:13 by Pierre Labastie, 7 years ago

Milestone: hold7.8
Owner: changed from blfs-book@… to Pierre Labastie
Status: newassigned

comment:14 by Pierre Labastie, 7 years ago

Summary: MesaLib-10.5.1 (placeholder)MesaLib-10.5.1

comment:15 by Pierre Labastie, 7 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r15650

Note: See TracTickets for help on using tickets.