Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#6148 closed enhancement (fixed)

libpeas-1.13.0

Reported by: bdubbs@… Owned by: Pierre Labastie
Priority: normal Milestone: 7.7
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description (last modified by Fernando de Oliveira)

New minor version

http://ftp.acc.umu.se/pub/gnome/sources/libpeas/1.13/libpeas-1.13.0.tar.xz

http://ftp.acc.umu.se/pub/gnome/sources/libpeas/1.13/libpeas-1.13.0.news

Overview of Changes in libpeas 1.13.0
====================================

* Removed support for Seed plugins
* Added support for Lua 5.1 plugins using the LGI bindings
* PeasEngine is now thread-safe
* Added support for non-global plugins loaders
* Load C plugins with local linkage
* Use Python to implement the plugin loader's logic
* Support Python plugins that define __all__
* Use Lua to implement the plugin loader's logic
* Prevent the accidental escaping of globals with Lua plugins
* Misc bugfixes

* Translation updates:
...

Change History (25)

comment:1 by Fernando de Oliveira, 7 years ago

Description: modified (diff)

This package can be LFS7.6 checked. Dependents build and work fine.

But I have a doubt.

We see in the news (above in the description):

"Added support for Lua 5.1 plugins using the LGI bindings"

Needs to use:

--enable-lua5.1

which obviously causes failure of config.

Include or not Lua 5.1 as optional dependency? How? "Broken with version in the book" doesn't seem to make much sense.

comment:2 by Fernando de Oliveira, 7 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

Will update, leaving alone lua issue.

comment:3 by Fernando de Oliveira, 7 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r15507.

comment:4 by Pierre Labastie, 7 years ago

For what is worth, if anybody comes to this ticket:

It seems that either luajit (http://luajit.org) or lua + lgi (https://github.com/pavouk/lgi) are needed for the lua bindings. Furthermore, configure only tests lua5.1.pc, so that you need to issue:

ln -sfv lua.pc /usr/lib/pkgconfig/lua5.1.pc

if you want lua to be found.

So, luajit and/or lgi+lua could be included in optional dependencies. But I am not sure it is worth it.

comment:5 by Fernando de Oliveira, 7 years ago

Resolution: fixed
Status: closedreopened

comment:6 by Fernando de Oliveira, 7 years ago

Keywords: blfs-book@lists.linuxfromscratch.org added
Status: reopenednew

It is odd. What they had in mind to be specifically writing in several parts of the code lua51, Lua 5.1 and alike?

Thanks, Pierre, for finding that. I've reopening and giving back to the book.

Please, if you can find time, would you mind fixing it?

BTW, I am missing you, Ken and Igor editing the book, and I am doing more than I really wanted. You two, please help me, because it would be nice more equilibration in the several people's contributions.

I believe Bruce thinks the same.

comment:7 by Fernando de Oliveira, 7 years ago

Keywords: blfs-book@lists.linuxfromscratch.org removed
Owner: changed from Fernando de Oliveira to blfs-book@…

comment:8 by Pierre Labastie, 7 years ago

Owner: changed from blfs-book@… to Pierre Labastie
Status: newassigned

I am sorry for not doing more, but I do not have much time. So when I see a new version of a package I know, I take it, but I hesitate to take packages I do not know, because sometimes, it takes a long time understand how it really works.

I take this ticket to add the optional deps, but I trust you for the various tests that have to be done (packages depending of libpeas, for example).

comment:9 by Pierre Labastie, 7 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r15511.

comment:10 by Fernando de Oliveira, 7 years ago

I understand you're busy. Sorry for the pressure.

Thank you very much for taking this ticket.

comment:11 by Pierre Labastie, 7 years ago

Well, I think I wrote something wrong in the note: it seems that the only version of LUA which would work is 5.1. It is amazing that they included such an old version of LUA in this new version of libpeas. Anyway, I'll remove the note, just leaving the optional deps.

comment:12 by Fernando de Oliveira, 7 years ago

That is why I closed without solving the issue. How to include these two libraries, if they will only work with lua-5.1?

I did a test yesterday, installed both optional dependencies, but could not get the enable lua 5.1 switch. What do you think of adding a comment after the two dependencies: "broken, because needs older version of lua"? Or something like that. Neither will will work, actually, because depend on lua-5.1.

If you agree, please do it. If not, I agree leaving it alone.

Again, thank you very much for taking this.

in reply to:  6 comment:13 by Fernando de Oliveira, 7 years ago

Replying to fo:

BTW, I am missing you, Ken and Igor editing the book, and I am doing more than I really wanted. You two, please help me, because it would be nice more equilibration in the several people's contributions.

I believe Bruce thinks the same.

To clarify.

I am not complaining of doing too much nor that editors should do more, I wanted to mean that all their contributions are essential for the book and contrarily to what was once written, I like their contributions very much. So, whenever you all find time, please take all tickets you wish. I can even pass a ticket from me to any of you, just ask for it.

comment:14 by Pierre Labastie, 7 years ago

No prob with what you wrote, Fernando, I have learned to know you, and I know you feel much pressure about updating the book.

Different subject. I just realized that "Seeds" should not be anymore in the optional deps (see first item in "news" above). I will fix that and also add something about the old version of Lua.

Has anybody tried luajit?

Last edited 7 years ago by Pierre Labastie (previous) (diff)

comment:15 by Fernando de Oliveira, 7 years ago

Yes, I had, yesterday, but mixed everything up.

I cannot see what it does for libpeas:

$ xzgrep -i lua libpeas-1.13.0-simulation-2015.02.16-12h06m08s.log.xz
checking for Lua 5.1 availability.... yes (luajit)
checking for LGI availability in Lua 5.1.... no
config.status: creating loaders/lua5.1/Makefile
config.status: creating loaders/lua5.1/resources/Makefile
config.status: creating peas-demo/plugins/luahello/Makefile
config.status: creating tests/libpeas/plugins/extension-lua/Makefile
        Lua 5.1 support               : no

Installed LuaJIT:

http://LuaJIT.org/download/LuaJIT-2.0.3.tar.gz &&
f14e9104be513913810cd59c8c658dc0  LuaJIT-2.0.3.tar.gz

time make -j8 amalg PREFIX=/usr &&
make install PREFIX=/usr

Installed libpeas:

./configure --prefix=/usr --enable-luajit

One after the other:

$ porg -sFdd libpeas-1.13.0 LuaJIT-2.0.3
1.4M  143  02/16/15 12:15  libpeas-1.13.0
1.5M   24  02/16/15 12:03  luajit-2.0.3

Tests (for libpeas):

DESTDIR build eog totem gedit

Successfully run old installed: eog totem gedit
Check the new libraries are open correctly.

eog
-rwxr-xr-x 1 root root 219742 Fev 16 12:15 /usr/lib/libpeas-1.0.so.0.1300.0
-rwxr-xr-x 1 root root 191601 Fev 16 12:15 /usr/lib/libpeas-gtk-1.0.so.0.1300.0

totem
-rwxr-xr-x 1 root root 219742 Fev 16 12:15 /usr/lib/libpeas-1.0.so.0.1300.0
-rwxr-xr-x 1 root root 191601 Fev 16 12:15 /usr/lib/libpeas-gtk-1.0.so.0.1300.0

gedit
-rwxr-xr-x 1 root root 219742 Fev 16 12:15 /usr/lib/libpeas-1.0.so.0.1300.0
-rwxr-xr-x 1 root root 191601 Fev 16 12:15 /usr/lib/libpeas-gtk-1.0.so.0.1300.
Last edited 7 years ago by Fernando de Oliveira (previous) (diff)

in reply to:  15 comment:16 by Fernando de Oliveira, 7 years ago

Replying to fo:

Edited previous comment, and reproduce here the new part, or it will not appear in the email.

I cannot see what it does for libpeas:

$ xzgrep -i lua libpeas-1.13.0-simulation-2015.02.16-12h06m08s.log.xz
checking for Lua 5.1 availability.... yes (luajit)
checking for LGI availability in Lua 5.1.... no
config.status: creating loaders/lua5.1/Makefile
config.status: creating loaders/lua5.1/resources/Makefile
config.status: creating peas-demo/plugins/luahello/Makefile
config.status: creating tests/libpeas/plugins/extension-lua/Makefile
        Lua 5.1 support               : no

comment:17 by Fernando de Oliveira, 7 years ago

Just seen your commit. Looks like it already covers luaJIT.

Thanks, Pierre.

comment:18 by Pierre Labastie, 7 years ago

Well, I did not wait for the answer, because we are not supposed to test all the optional deps. But it is good to have something to answer to people who ask. So, I understand that the lua plugin does not work with luaJIT either, does it?

comment:19 by Fernando de Oliveira, 7 years ago

This is what I understand. It finds luajit, but not Lua 5.1, which seems to imply that it is not using found luajit.

With or without luajit installed, I cannot see any file added or missing.

comment:20 by Fernando de Oliveira, 7 years ago

Pierre, still about this issue.

I just read again the comment you included:

"it seems that LGI works only with LUA-5.1"

I was thinking if you find better to include both failing with LUA-5.1:

"they seem to work only with LUA-5.1"

What do you think?

Last edited 7 years ago by Fernando de Oliveira (previous) (diff)

comment:21 by Pierre Labastie, 7 years ago

Still working on this. I understand that LuaJIT-2.0.3 does not need LUA-5.3 in the book, and that its ABI is 5.1. So Right now, I am trying a build with just LuaJIT. I am not sure whether it would need LGI or not.

But I have an issue with gobject-introspection (so that GKT+3, which is needed, does not build), and I am investigating that too...

comment:22 by Fernando de Oliveira, 7 years ago

OK. Thanks.

comment:23 by Pierre Labastie, 7 years ago

Here is what I have found up to now: -LuaJIT may be built standalone, and has the 5.1 ABI -libpeas needs LGI, even with LuaJIT (so the "or" in the present version of the book should be "and") -LGI cannot be built with LuaJIT (lua.h is not at the expected location) -If LGI is built with LUA-5.3, it expects ABI 5.2 or more, and does not work with LuaJIT.

I begin to think I am wasting my time. I'll change the book one last time, and "basta!"

comment:24 by Fernando de Oliveira, 7 years ago

LOL. Yes, it is a PITA. I spent a lot of time along the same lines you did, without success. That is the reason I closed initially with a decision about it.

Thanks, again.

in reply to:  24 comment:25 by Fernando de Oliveira, 7 years ago

Replying to fo:

LOL.

It was for your "basta!". From what I remember, this is not French, it is Portuguese.

Note: See TracTickets for help on using tickets.