Opened 7 years ago

Closed 7 years ago

#6355 closed enhancement (fixed)

p11-kit-0.23.1

Reported by: Fernando de Oliveira Owned by: Fernando de Oliveira
Priority: normal Milestone: 7.8
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

http://p11-glue.freedesktop.org/releases/p11-kit-0.23.1.tar.gz

http://lists.freedesktop.org/archives/p11-glue/2015-February/000554.html

What's new in 0.23.1
--------------------

 * Use new PKCS#11 URI draft fields for URIs [#86474 #87582]
 * Add pem-directory-hash extract format
 * Build fixes


Detailed changes between 0.22.1 and 0.23.1
------------------------------------------

Adam Williamson (1):
      trust: Add pem-directory-hash extract format

Michael Cronenworth (1):
      compat: Add definition for setenv for Win32

Nikos Mavrogiannopoulos (3):
      Added support for pin-value PKCS#11 URI element
      Added test for pin-value
      Generate URIs compliant to the PKCS#11 URI draft in LC

Stef Walter (3):
      uri: Accept 'type' in additon to 'object-type' in PKCS#11 URIs
      p11-kit: Remove duplicate WHITESPACE define
      Release version 0.23.1

Change History (5)

comment:1 by Fernando de Oliveira, 7 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

comment:2 by Fernando de Oliveira, 7 years ago

Resolution: invalid
Status: assignedclosed

Thanks for warning me that this is a development version, although Arch Linux is using it (they are in the second distribution release of it: p11-kit-0.23.1-2).

comment:3 by Fernando de Oliveira, 7 years ago

Resolution: invalid
Status: closedreopened

Reopening. I'm trying to do some tickets that are in hold. That i the reason I din't create libvpx as hold.

Now, I'm trying to do #6380 gnutls-3.4.0 (placeholder).

Needed:

nettle-3.1.1 (actually, nettle-3, but 3.1.1 is the latest).

p11-kit >= 0.23.1.

I'll try to test the whole chain, including dependents of the three packages, and if successful, will do the three tickets: this one #6355, #6380 gnutls-3.4.0 (placeholder) and #5152 nettle-3.1.1 (placeholder).

Last edited 7 years ago by Fernando de Oliveira (previous) (diff)

comment:4 by Fernando de Oliveira, 7 years ago

Correcting my previous comment: at least nettle-3.1 is required for gnutls-3.4.0.

comment:5 by Fernando de Oliveira, 7 years ago

Resolution: fixed
Status: reopenedclosed

Fixed at r15878.

Note: See TracTickets for help on using tickets.