Opened 6 years ago

Closed 6 years ago

#6655 closed enhancement (fixed)

doxygen-1.8.10

Reported by: bdubbs@… Owned by: Fernando de Oliveira
Priority: normal Milestone: 7.8
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description (last modified by Fernando de Oliveira)

New point version

http://ftp.stack.nl/pub/users/dimitri/doxygen-1.8.10.src.tar.gz

ftp://ftp.stack.nl/pub/users/dimitri/doxygen-1.8.10.src.tar.gz

http://sourceforge.net/p/doxygen/mailman/message/34246842/

http://www.stack.nl/~dimitri/doxygen/manual/changelog.html

Changelog

1.8 Series
Release 1.8.10

(release date 27-06-2015)

    change the build system to use cmake
    Add support for basic XML syntax highlighting.
    Added documentation for ``` style fenced code block and more robust
    parsing
    Added function arguments to the LaTeX toc
    Added missing files and build instructions
    Added missing libraries for building doxysearch on Windows
    Added support for language codes
    Added type constraint relations for Java generics to dot graphs and
    XML output
    Adding commands \hidecallgraph and \hidecallergraph
    Adjust test script for longer version number
    Adjusted version in configure script
    Alignment of project name
    Allow selection of specific translators to compile in at build time
    Based on the report of Peter D. Barnes in the doxygen forum
    (http://doxygen.10944.n7.nabble.com/doxygen-1-8-9-1-upgrade-errors-td6990.html)
    Better error message in case of IDL inconsistency
    Bug 659590 - EXTRA_PACKAGES can't handle package options
    Bug 739680 - Using HTML entities in PROJECT_NAME
    Bug 742095 - Missing documentation after nested C++11 unified
    initializer
    Bug 742151 - Bogus warning: citelist: Unexpected new line character
    Bug 742230 - @todo paragraphs incorrectly placed in rtf output
    Bug 742235 - Bogus message with addtogroup
    Bug 742408 - Configuring doxyfile to only output docbook produces
    erroneous warning
    Bug 742427 - latex compilation: \backmatter incompatible with
    COMPACT_LATEX=YES
    Bug 742445 - Wrong icons in TOC of CHM help
    Bug 742899 - <CAPTION> inside <TABLE> no longer works for LaTex
    output
    Bug 743604 - Duplicate anchors from tagfiles
    Bug 743605 - Tagfile anchors not generated for enumeration values
    Bug 743675 - Non-ascii characters are not emphasised
    Bug 744762 - Using TAGFILES prevents symbol extraction
    Bug 745439 - PATCH: please consider making doxygen output byte for
    byte identical between individual runs by default
    Bug 745481 - Doxygen generates bad "More..." file links for
    functions within a namespace
    Bug 745870 - [PATCH] QT4's qmake is titled differently on Fedora 21
    Bug 746226 - last enum member not documented
    Bug 746417 - Nested list in C# XML comments closes outer list
    prematurely
    Bug 746614 - Bogus warning regarding nested comments
    Bug 746619 - Bogus warnings in case of anonymous namespace and @todo
    Bug 746734 - Don't warn about missing documentation for deleted
    functions.
    Bug 747111 - Table of content incorrect with escaped symbols
    Bug 747780 - man output should escape minus signs
    Bug 748208 - Bug #313527 regression - Enum in bitfield is not parsed
    properly.
    Bug 750016 - FILE_PATTERNS ignores arbitrary extensions
    Bug 751455 - class scoped enum documentation appearing at group
    level instead of class level
    Build fixes for windows build
    Bump copyright year
    Bump version in configure script
    Cleanup & adapt travis config
    Consistency in handling HTML and LaTeX in respect to header and
    footer
    Correct string buffer sizes for RTF output, such that the string is
    always correctly sized.
    Crash in case of non generic interface in Fortran
    Documentation HTML Header, Footer, and Stylesheet changes
    Documenting RESULT variable of Fortran FUNCTION
    Doxygen LaTeX / PDF links point to page 1
    Enable relative paths referenced source files
    Escape "@" in names as it is not allowed in XML / Docbook names
    (comming from anon namespaces)
    Fix for bug 746673.
    Fix for building diagram example conditionally
    Fix for issue 744670
    Fix for issue 744671
    Fix for rendering the template parameters of members of variadic
    template classes.
    Fix missing brief documentation for overload and specialization
    functions
    Fix nesting of XML tag "literallayout" for docbook output of enums.
    Fix parsing of ODL-style properties
    Fix potential null pointer dereference in src/classdef.cpp
    Fix potential null pointer dereference in src/context.cpp
    Fixed a couple of cases where sharing string data could lead to
    corruption
    Fixed code reachability bug found by coverity in translator_fi.h
    Fixed compilation issue on Windows
    Fixed issue accessing uninitialized buffer under certain conditions.
    Fixed potential crash while generating dot graphs
    Fixed potential string buffer issue for dot graphs
    Fixed regression due to buffer resizing while generating RTF.
    Fixed regression in argument processing
    Fixed type in printdocvisitor.h
    Fixed typos in comments.
    Fixes for showing type constraint relations
    Fortran FUNCTION source code
    Fortran: code color GOTO as flow keyword.
    Fortran: fixed format position 73 and further is comment
    Fortran: warning message about not documented module member
    Guarded debug prints against printing a NULL pointer.
    HTML entity &deg; gives problems in LaTeX
    Help message regarding layout file,[view]
    Internal debug option -d lex is not described
    Internal doxygen docs gives: warning: Unsupported xml/html tag <...>
    found
    Missing cross reference link
    Patch fixing a typo in Pull Request 307
    Prevent example.tag from being regenerated
    Problem running tests under Windows
    Remove the new line after @startuml in generated pu file
    Remove unreachable code
    Remove unused local and static global variables
    Remove wrong </File>
    Removed OS version check for MACOSX (was not used anywhere)
    Removed dbus XML parser, various refinements
    Removed old build files, added install targets and other options
    Repair Doxygen generate invalid styleSheetFile and extensionsFile of
    RTF
    Replace to_c_cmd by resource compiler
    Restore deleted file
    Showing grey/gray in documentation
    Suggestion to use stripPrefix has been implemented for RESULT. For
    consistency also implemented for arguments.
    Support diff that returns "No differences encountered" when
    comparing test results
    Support generating index-color PNG files
    Switched back to version 6.2 of JavaCC for VHDL parser generation.
    Tcl: fix for extra line breaks in source browser introduced by
    commit 312bef5
    TranslatorSwedish updated
    Update of search from "endless search to 'Character search:
    criterion.
    Update translator_cn.h
    Updated changelog for 1.8.9.1
    Updated installation section of the manual
    Various VHDL related fixes
    Various minor changes
    Warning message multiple mainpages
    Warnings without filename
    add support for github flavored fenced code blocks
    added HHC.exe own output to the debug output when extcmd flag
    enabled
    doc/translator.py -- minor updates
    drop #include <unistd.h>
    fix *.l for three backticks
    fix enum brief description in RTF output
    fix for CHM TOC "Classes" entry to point to annotated file
    fix for src/translator_tw.h by Gary Lee (translation cleaned)
    increase the size of l when result is modified
    move layout_default.xml to templates/html/
    runtests.pl: mmn version has dash as separator
    specify that doxygen searches files in INPUT tag
    sqlite3: add regexp searches to search.py
    sqlite3: add schema comments
    sqlite3: fix constness
    version.py pass configure file path as parameter
    xml: use STRIP_FROM_PATH on @file attributes.

Change History (3)

comment:1 by Fernando de Oliveira, 6 years ago

Description: modified (diff)

comment:2 by Fernando de Oliveira, 6 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

comment:3 by Fernando de Oliveira, 6 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r16184.

Note: See TracTickets for help on using tickets.