Opened 17 years ago

Closed 17 years ago

Last modified 7 years ago

#670 closed defect (fixed)

rept-gtk fails to compile with gtk-2.4 Im including the fix

Reported by: spikeoreo@… Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords:
Cc:

Description

Just doing a new install of blfs-cvs and get this error when trying to run make on rep-gtk

In file included from rep-types.c:24: rep-gtk.h:294: error: conflicting types for `gtk_radio_menu_item_new_with_label_from_widget' /usr/include/gtk-2.0/gtk/gtkradiomenuitem.h:79: error: previous declaration of `gtk_radio_menu_item_new_with_label_from_widget' rep-gtk.h:297: error: conflicting types for `gtk_radio_menu_item_new_with_mnemonic_from_widget' /usr/include/gtk-2.0/gtk/gtkradiomenuitem.h:77: error: previous declaration of `gtk_radio_menu_item_new_with_mnemonic_from_widget' make: * [rep-types.lo] Error 1

Here is the fix

The problem is that now gtk-2.4 defines 2 functions as const gchar instead of just gchar

edit rep-gtk.h and on lines 294 and 297 put const in front of gchar like below

GtkWidget* gtk_radio_menu_item_new_with_label_from_widget (GtkRadioMenuItem *group,

const gchar *label);

GtkWidget* gtk_radio_menu_item_new_with_mnemonic_from_widget (GtkRadioMenuItem *group,

const gchar *label);

Also edit gtk-compat.c and also add const in front of gchar on lines 68 and 76 like as follows

GtkWidget* gtk_radio_menu_item_new_with_label_from_widget (GtkRadioMenuItem *group,

const gchar *label)

{

GSList *g = group? gtk_radio_menu_item_group (group) : NULL; return gtk_radio_menu_item_new_with_label (g, label);

}

GtkWidget* gtk_radio_menu_item_new_with_mnemonic_from_widget (GtkRadioMenuItem *group,

const gchar *label)

And thats athe athe athe a thats all folks

Attachments (1)

rep-gtk-gtk2.4.patch (1.5 KB ) - added by spikeoreo@… 17 years ago.
patch for rep-gtk-0.18

Download all attachments as: .zip

Change History (3)

by spikeoreo@…, 17 years ago

Attachment: rep-gtk-gtk2.4.patch added

patch for rep-gtk-0.18

comment:1 by igor@…, 17 years ago

Resolution: fixed
Status: newclosed

comment:2 by bdubbs@…, 7 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.