Opened 6 years ago

Closed 6 years ago

#6941 closed enhancement (fixed)

sddm-0.12.0

Reported by: Fernando de Oliveira Owned by: bdubbs@…
Priority: high Milestone: 7.8
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Problems

I am having problems with previous version 0.11.0. Have already reported to Bruce. Cannot remember the last time I told Ken that all LXQt exit buttons were working here. Cannot remember what i did for them to work. Cannot remember if Ken solved his problem.

I installed this version, and apparently after, problems appeared.

En passant, build instructions needed to be modified, switches and sed's.

Removed all (0.11.0 and 0.12.0), installed back 0.11.0.

Fact is that only exit session is working, now. For LXDE, LXQt and XFce.

But if I start at runleve 3, with ck-launch-session dbus-launch --exit-with-session start... or from LXDE (runlevel 5), everything works.

Wrote all that, because I am not sure about what to do.

  1. Remove temporarly sddm from 7.8, to restart working at SVN?
  1. Try to fix it (it is taking days from me)?
  1. Try to update to 0.12.0 and see if can make this version work for 7.8?

Milestone will be 7.8, , priority high, until we decide what to do, and if it only does not work for me, good, we change for milestone 7.9, priority normal.

Data for the new version

https://github.com/sddm/sddm/releases/download/v0.12.0/sddm-0.12.0.tar.xz

There is a detailed 0.12.0 Release Announcement:

https://github.com/sddm/sddm/wiki/0.12.0-Release-Announcement

but below, I reproduce just of what could be named News.

https://github.com/sddm/sddm/releases/tag/v0.12.0

SHA1:

985aee2bbafd42969353786cc3dd63b2695cb848

Version 0.12.0

@plfiorini plfiorini released this 11 days ago · 10 commits to master
since this release

We are proud to announce the immediate availability of SDDM 0.12.0.

This release features working Wayland sessions for the first time, but
the greeter is still running on Xorg.

This means that you will be able to login into a Wayland desktop
environment without problems however the greeter screen still depends on
X11.

Work on the Wayland support for the greeter has already been started and
will likely be available with the next release.

Highlights of this release:

  • BACKWARDS-INCOMPATIBLE: SDDM now depends on Qt >= 5.3
  • BACKWARDS-INCOMPATIBLE: Display setup script is now killed if it
    hasn't finished within 30 seconds.
  • LICENSING: The Maldives non-free background has been replaced by a
    CC-BY-SA alternative
  • WAYLAND: Wayland sessions support
  • CONFIG: New sddm.conf option XephyrPath (defaults to
    /usr/bin/Xephyr)
  • CONFIG: new sddm.conf option ServerArguments (defaults to -nolisten
    tcp)
  • CONFIG: new sddm.config option DisplayStopCommand (executes Xstop)
  • THEMES: Assorted improvements to the default theme
  • BUGFIX: Honor TryExec in Xsession desktop files
  • BUGFIX: Fix session startup on zsh
  • BUILD: Allow setting a custom DBUS_CONFIG_FILENAME at compile time
  • BUILD: Allow SYSTEMD_SYSTEM_UNIT_DIR to be overridden at compile
    time
  • BUILD: Allow QT_IMPORTS_DIR to be overridden at compile time
  • BUILD: No longer hardcode min/max UIDs, allow setting UID_MIN and
    UID_MAX at compile time
  • BUILD: Assorted FreeBSD fixes
  • BUILD: Fix build warnings with Qt 5.5.
  • BUILD: Enable QT_NO_CAST_FROM_ASCII
  • I18N: Added Arabic, contributed by Safa Alfulaij
  • I18N: Added Hungarian, contributed by @mortein79
  • I18N: Various i18n updates and improvements
  • I18N: Full right-to-left languages support.

More information can be found here.

Change History (4)

comment:1 by bdubbs@…, 6 years ago

Resolution: fixed
Status: newclosed

Fixed at revision 16423.

This package also needed ConsoleKit2-1.0.0.

comment:2 by Fernando de Oliveira, 6 years ago

Resolution: fixed
Status: closedreopened

comment:3 by Fernando de Oliveira, 6 years ago

Owner: changed from blfs-book@… to bdubbs@…
Status: reopenednew

comment:4 by Fernando de Oliveira, 6 years ago

Resolution: fixed
Status: newclosed

Thank you, Bruce for solving this nightmare.

Took the liberty to reopen, reassign to you and closed.

Thanks, Ken for the patience and discussions.

Note: See TracTickets for help on using tickets.