Opened 6 years ago

Closed 6 years ago

#6966 closed enhancement (fixed)

cairomm-1.12.0

Reported by: Fernando de Oliveira Owned by: Pierre Labastie
Priority: normal Milestone: 7.9
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

I'm creating this ticket because perhaps some stable package from gnome needs it, or it was a typo to be marked as unstable and will only update the ticket in the necessary parts.

Anyway, the News below will be useful, if we have to wait until next stable, probably cairomm-1.12.1.

http://ftp.gnome.org/pub/gnome/sources/cairomm/1.12/cairomm-1.12.0.tar.xz

http://ftp.gnome.org/pub/gnome/sources/cairomm/1.12/cairomm-1.12.0.sha256sum

a54ada8394a86182525c0762e6f50db6b9212a2109280d13ec6a0b29bfd1afe6

http://ftp.gnome.org/pub/gnome/sources/cairomm/1.12/cairomm-1.12.0.news

1.12.0 (unstable):

* Cairo::RefPtr: Add move constructors and move operator=().
  (Murray Cumming)
* MSVC build fixes.
  (Chun-wei Fan)

1.11.4 (unstable):

* Use (and require) C++11.
  (Murray Cumming)
* Add Script and ScriptSurface.
  (Povilas Kanapickas)
* Context: get_surface_wrapper(): Handle CAIRO_SURFACE_TYPE_SCRIPT,
  returning a ScriptSurface.
  (Povilas Kanapickas)
* Surface: get_device(): Handle CAIRO_SURFACE_TYPE_SCRIPT,
  returning a Script.
  (Povilas Kanapickas)
* Wrap cairo script device and script surface APIs.
  (Povilas Kanapickas)
* FtFontFace: Add get/set/unset_synthesize().
  (Povilas Kanapickas)
* Update MSVC.Net 2010 project files.
  (David Weiß)

1.11.2 (unstable):

* Pattern: Add set_extend() and get_extend().
  (Povilas Kanapickas) Bug #73775
* ScaledFont: Add the missing get_extents() method implementation.
  (Murray Cumming) Bug #53981 (cheshirekow)
* Allow use from Objective-C instead of just allowing building.
  (Anton Bachin) Bug #66328
* Avoid dereferencing empty std::vector<>s.
  (Murray Cumming) Bug #36020 (Robert Kurjata)
* Documentation improvements.
  (Mark Vender)
* Fix linker problems in examples.
  (Murray Cumming)

Change History (5)

comment:1 by Armin K, 6 years ago

Milestone: hold7.9
Summary: cairomm-1.12.0 (marked unstable - placeholder)cairomm-1.12.0

Unstable is probably a copy/paste mistake or a typo. This package is required for latest *mm stack due to switching to C++11.

comment:2 by Pierre Labastie, 6 years ago

Owner: changed from blfs-book@… to Pierre Labastie
Status: newassigned

comment:3 by Pierre Labastie, 6 years ago

Confirmed that pangomm-2.38.1 requires cairomm-1.12.0

in reply to:  3 comment:4 by Fernando de Oliveira, 6 years ago

Replying to pierre.labastie:

Confirmed that pangomm-2.38.1 requires cairomm-1.12.0

Thanks. This confirms what I suspected in the description:

I'm creating this ticket because perhaps some stable package from gnome needs it, or it was a typo to be marked as unstable and will only update the ticket in the necessary parts.

comment:5 by Pierre Labastie, 6 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r16515

Note: See TracTickets for help on using tickets.