Opened 6 years ago

Closed 6 years ago

#7185 closed defect (fixed)

Doxygen does not build with flex-2.6.0

Reported by: Pierre Labastie Owned by: Pierre Labastie
Priority: normal Milestone: 7.9
Component: BOOK Version: SVN
Severity: major Keywords:
Cc:

Description (last modified by Pierre Labastie)

I have installed flex-2.6.0 from the LFS book. When building doxygen-1.8.10, I get:

code.l:3700:2: error: #error "You seem to be using a version of flex newer
than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen!
Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"

Change History (5)

comment:1 by Pierre Labastie, 6 years ago

Description: modified (diff)

comment:2 by bdubbs@…, 6 years ago

There is a patch at https://github.com/doxygen/doxygen/pull/413/files that should work.

comment:3 by Pierre Labastie, 6 years ago

Upstream has merged a slightly more elaborate version of the patch: https://github.com/doxygen/doxygen/commit/8c51120ad55b440b738ef0b96f8169d84a7ae88a and https://github.com/doxygen/doxygen/commit/a8c73cdbe37cc53c398002d20e94037552a8fb55 (the first patch had a typo). But the patch of comment:2 should be enough

comment:4 by Pierre Labastie, 6 years ago

Owner: changed from blfs-book@… to Pierre Labastie
Status: newassigned

comment:5 by Pierre Labastie, 6 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r16693

Note: See TracTickets for help on using tickets.