Opened 8 years ago

Closed 8 years ago

#7185 closed defect (fixed)

Doxygen does not build with flex-2.6.0

Reported by: Pierre Labastie Owned by: Pierre Labastie
Priority: normal Milestone: 7.9
Component: BOOK Version: SVN
Severity: major Keywords:

Description (last modified by Pierre Labastie)

I have installed flex-2.6.0 from the LFS book. When building doxygen-1.8.10, I get:

code.l:3700:2: error: #error "You seem to be using a version of flex newer
than 2.5.4 but older than 2.5.33. These versions do NOT work with doxygen!
Please use version <=2.5.4 or >=2.5.33 or expect things to be parsed wrongly!"

Change History (5)

comment:1 by Pierre Labastie, 8 years ago

Description: modified (diff)

comment:2 by bdubbs@…, 8 years ago

There is a patch at that should work.

comment:3 by Pierre Labastie, 8 years ago

Upstream has merged a slightly more elaborate version of the patch: and (the first patch had a typo). But the patch of comment:2 should be enough

comment:4 by Pierre Labastie, 8 years ago

Owner: changed from blfs-book@… to Pierre Labastie
Status: newassigned

comment:5 by Pierre Labastie, 8 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r16693

Note: See TracTickets for help on using tickets.