Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7220 closed enhancement (fixed)

libwww-perl-6.15 (perl module)

Reported by: Fernando de Oliveira Owned by: bdubbs@…
Priority: normal Milestone: 7.9
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

http://www.cpan.org/authors/id/E/ET/ETHER/libwww-perl-6.15.tar.gz

http://www.cpan.org/authors/id/E/ET/ETHER/CHECKSUMS

'md5' => '6888c9d8728cd6f3ea3c9754461c9f94'

https://metacpan.org/changes/distribution/libwww-perl

or

http://cpansearch.perl.org/src/ETHER/libwww-perl-6.15/Changes

or

https://api.metacpan.org/source/ETHER/libwww-perl-6.15/Changes

________________________________________________________________________
2015-12-15  Release 6.15

    (special thanks to Chase Whitener for testing many of these changes
    out in 6.14_001!)

Graham Knop (1):
    - tests now use localhost rather than a net-accessible address
      (PR#76)

Michael Schwern (1):
    - fixed some tests to do what they intended (regex rather than
      boolean checks) (from PR#28)

Joe Atzberger (2):
    - conversion of some tests from Test.pm to Test::More (from PR#29)

Piotr Roszatycki (1):
    - use File::Temp for randomized tempdir (PR#53)

Change History (10)

comment:1 by Fernando de Oliveira, 6 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

comment:2 by Fernando de Oliveira, 6 years ago

Owner: changed from Fernando de Oliveira to blfs-book@…
Status: assignednew

Sorry, thought I had done this before, but I was wrong.

comment:3 by bdubbs@…, 6 years ago

I can do it if you want, but it is really easy:

perl Makefile.PL &&
make &&
make test

sudo make install

The dependencies are listed int he README.

comment:4 by Fernando de Oliveira, 6 years ago

Thanks for doing it.

My problem is how to test it: only biber...

comment:5 by bdubbs@…, 6 years ago

Owner: changed from blfs-book@… to bdubbs@…
Status: newassigned

For -dev, the internal tests are good enough. Everything gets a more thorough test before release.

comment:6 by Fernando de Oliveira, 6 years ago

OK. Thanks for that. Will do next time.

comment:7 by bdubbs@…, 6 years ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 16711.

in reply to:  5 comment:8 by ken@…, 6 years ago

Replying to bdubbs@…:

For -dev, the internal tests are good enough. Everything gets a more thorough test before release.

No objections to that. In this case it is also used by perl-html-parser [ HTML::Parser ] so that could have been used to test it - it is an optional dep for libxfce4ui. I only checked this because I remembered that it had been in the book for many years (i.e. before biber).

comment:9 by bdubbs@…, 6 years ago

Let me clarify a bit. For support packages and libraries, testing with packages that use the target can be difficult. You can run the package that depends on the target, but there is no guarantee that particular library, program, or in this case, perl module is used. Usually though running any internal tests is sufficient for BLFS.

Integrated testing is really the job of upstream, but sometimes we can get ahead of them.

If the target package is an end program, then it is reasonable to exercise at least some of the basic functions when updating.

comment:10 by Fernando de Oliveira, 6 years ago

Thanks to both of you.

Ken, thanks for the clarifications. I reproduced the text in my script libwww-perl-6.15.sh.

I knew it was there before biber, but due to hurry caused by gcc or simple ignorance, missed the other dependents.

Still have problem finding dependents for perl modules.

Note: See TracTickets for help on using tickets.