Opened 6 years ago

Closed 6 years ago

#7379 closed enhancement (fixed)

gstreamer-1.6.3, gst-plugins-base-1.6.3, gst-plugins-good-1.6.3, gst-plugins-bad-1.6.3, gst-plugins-ugly-1.6.3, and gst-libav-1.6.3

Reported by: Fernando de Oliveira Owned by: Fernando de Oliveira
Priority: normal Milestone: 7.9
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-1.6.3.tar.xz

http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-1.6.3.tar.xz.sha256sum

22f9568d67b87cf700a111f381144bd37cb93790a77e4e331db01fe854a37f24

http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-1.6.3.tar.xz

http://gstreamer.freedesktop.org/src/gst-plugins-base/gst-plugins-base-1.6.3.tar.xz.sha256sum

b6154f8fdba4877e95efd94610ef0ada4f0171cd12eb829a3c3c97345d9c7a75

http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-1.6.3.tar.xz

http://gstreamer.freedesktop.org/src/gst-plugins-good/gst-plugins-good-1.6.3.tar.xz.sha256sum

24b19db70b2a83461ebddfe20033db432dadfdb5d4b54ffb1dfa0d830134a177

http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-1.6.3.tar.xz

http://gstreamer.freedesktop.org/src/gst-plugins-bad/gst-plugins-bad-1.6.3.tar.xz.sha256sum

971b29101d6a9c5e3fe94d99d977a227f58f0b2d29b6ca2c7f292052542b3a61

http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-1.6.3.tar.xz

http://gstreamer.freedesktop.org/src/gst-plugins-ugly/gst-plugins-ugly-1.6.3.tar.xz.sha256sum

2fecf7b7c7882f8f62f1900048f4013f98c214fb3d3303d8d812245bb41fd064

http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-1.6.3.tar.xz

http://gstreamer.freedesktop.org/src/gst-libav/gst-libav-1.6.3.tar.xz.sha256sum

857b9c060a0337de38c6d26238c47352433c02eabf26c2f860c854dbc35bd4ab

http://lists.freedesktop.org/archives/gstreamer-announce/2016-January/000367.html

or

http://gstreamer.freedesktop.org/releases/1.6/

RELEASE: GStreamer Core and Plugins 1.6.3 stable release
Sebastian Dröge sebastian at centricular.com
Wed Jan 20 05:20:39 PST 2016

The GStreamer team is proud to announce the third bugfix release in the
stable 1.6 release series of your favourite cross-platform multimedia
framework!

This release only contains bugfixes and it is safe to update from 1.6.x.
For a full list of bugfixes see Bugzilla:
https://bugzilla.gnome.org/buglist.cgi?bug_status=RESOLVED&bug_status=VERIFIED&limit=0&list_id=91562&order=bug_id&product=GStreamer&resolution=FIXED&target_milestone=1.6.3

Major bugfixes

- Fix regression in GL library that made glimagesink unsable on Android
- Integer arithmetic overflow in queue2 element that could break
  buffering or cause crashes due to NULL pointer dereference
- Fix crash in AAC/ADTS typefinder caused by reading more memory than is
  available
- Stop ignoring encoder errors in the VP8/VP9 encoders
- Deprecate GstVideoEncoder GST_VIDEO_ENCODER_FLOW_DROPPED. It's
  redudant and was never actually implemented
- Ensure to store the correct video info in GstVideoBufferPool
- Fix caps in rtspsrc when doing SRTP over interleaved TCP
- Fix crash in pcap parser on 0-sized packets
- Clear EOS flag in appsrc to allow reuse after EOS and flushing
- Ignore flushing streams in streamsynchronizer during stream switches
  to fix problems caused by this in gst-editing-services
- Ignore tags and other metadata in WAV files after the "data" chunk in
  PUSH mode to prevent them from being interpreted as audio
- Correctly use colorimetry in v4l2 only for YUV color formats
- Set reserved bits in MPEG TS muxer to 1s
- Fix calculation of SBC frame lengths
- Fix output of the RTP JPEG2000 depayloader to have one frame per
  buffer and crash in the OpenJPEG decoder on incomplete frames
- Update ffmpeg snapshot in gst-libav to 2.8.5
- Memory leak fixes in scaletempo, the raw video RTP depayloader, and in
  playsink related to audio/video filters
- Fixes for error handling in the OSX audio plugin
- Various gobject-introspection annotation fixes and additions
- Compiler warning fixes for latest clang compiler
- and many, many more:
  https://bugzilla.gnome.org/buglist.cgi?bug_status=RESOLVED&bug_status=VERIFIED&limit=0&list_id=91562&order=bug_id&product=GStreamer&resolution=FIXED&target_milestone=1.6.3

...

-- 
Sebastian Dröge, Centricular Ltd · http://www.centricular.com

Change History (2)

comment:1 by Fernando de Oliveira, 6 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: newassigned

comment:2 by Fernando de Oliveira, 6 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r16825.

Note: See TracTickets for help on using tickets.