Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#7462 closed defect (fixed)

vlc fails to work with lua if not compiled with -DLUA_COMPAT_5_1

Reported by: Tim Tassonis Owned by: Fernando de Oliveira
Priority: low Milestone: 7.9
Component: BOOK Version: SVN
Severity: minor Keywords:
Cc:

Description

When compiling and installing vlc 2.2.2 with lua 5.3.2 support according to BLFS svn , the compile went fine, but when I started vlc, I got the error:

core demux meta error: corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

After some google "research" I found this post:

http://www.linuxquestions.org/questions/linux-from-scratch-13/vlc-and-corrupt-lua-module-errors-4175556933/

So, I recompiled lua with:

CFLAGS=' -fPIC -O2 -Wall -Wextra -DLUA_COMPAT_5_1 $(SYSCFLAGS) $(MYCFLAGS)'

make CFLAGS="$CFLAGS" linux

and the problem went away. (I'm quite sure there's a more elegant way to force -DLUA_COMPAT_5_1...)

Maybe this could be noted on either the lua or the vlc page.

Change History (13)

comment:1 by Fernando de Oliveira, 6 years ago

Resolution: wontfix
Status: newclosed

Please, next time you report anything, code and logs should be between

So that we can copy and paste. I am here copying for the html.

timtass disse:

So, I recompiled lua with:

CFLAGS=' -fPIC -O2 -Wall -Wextra -DLUA_COMPAT_5_1 $(SYSCFLAGS) $(MYCFLAGS)'

make CFLAGS="$CFLAGS" linux

and the problem went away. (I'm quite sure there's a more elegant way to force -DLUA_COMPAT_5_1...)

Maybe this could be noted on either the lua or the vlc page.

This is a completely meaningless sentence.

My first attempt

/logs/vlc-2.2.2-simulation-2016.02.14-00h02m03s.log.xz

config.status: creating po/Makefile

libvlc configuration
--------------------
version               : 2.2.2
system                : linux
architecture          : x86_64 mmx sse sse2
optimizations         : yes
vlc aliases           : cvlc rvlc qvlc svlc nvlc

To build vlc and its plugins, type `make', or `./compile' if you like
nice colors.
CFLAGS=  -fPIC -O2 -Wall -Wextra -DLUA_COMPAT_5_1 $(SYSCFLAGS) $(MYCFLAGS)
make: *** No rule to make target 'linux'.  Pare.

Did this timtass really run the instructions? In BLFS? Which BLFS (the other day he "accidentally" use 7.8, instead of svn)?

My second attempt

remove "linux" from "make" line

After install, still error, which I knew about nut has yet been solved.

... corrupt module: /usr/lib/vlc/plugins/lua/liblua_plugin.so

Reports from Tim Tassonis are a few times correct about the existence of errors, but solutions have not been tried or are somewhat wrong.

In the first reports, he demonstrated he does not follow the book exactly.

And he is eager into find problems.

If I take seriously his reports, I waste normally two days of work.

Any future report by him, either someone take, or I will leave for the day/month/year I have time.

And one important thing: he was very rude in one of the first post suspecting of my build. Recently, he included the word fuck in a reply to me.

That is the reason his email is blocked.

comment:2 by Fernando de Oliveira, 6 years ago

Resolution: wontfix
Status: closedreopened

comment:3 by Fernando de Oliveira, 6 years ago

Owner: changed from blfs-book@… to Fernando de Oliveira
Status: reopenednew

comment:4 by Fernando de Oliveira, 6 years ago

Resolution: wontfix
Status: newclosed

comment:5 by Fernando de Oliveira, 6 years ago

Resolution: wontfix
Status: closedreopened

transferred to #7465.

comment:6 by Fernando de Oliveira, 6 years ago

Status: reopenednew

comment:7 by Fernando de Oliveira, 6 years ago

Status: newassigned

comment:8 by Fernando de Oliveira, 6 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r16972.

comment:9 by Tim Tassonis, 6 years ago

First of all: I wrote exactly this:

So, I recompiled lua with:

CFLAGS=' -fPIC -O2 -Wall -Wextra -DLUA_COMPAT_5_1 $(SYSCFLAGS) $(MYCFLAGS)'
make CFLAGS="$CFLAGS" linux

I recompiled lua and not vlc, like you did. I tested it and it works. Your accusation that I have not tested this is wrong.

And about your other accusations: I am not at all eager into finding problems. I am a great admirer of your work and have built hundreds of packages in blfs/lfs without any problems. When I encounter one and am able to fix it, I report it to trac/the list in the hope of helping to make the books even better that they already are, and they are already exceptionally good.

I usually follow the book by the word, except that I install into $DESTDIR, but none of my reports have been caused by this. I do a lot of errors myself and only report back when I'm absolutely sure the issue is not with my modifications, but with the instructions.

You can always come again with the one time I accidentally used 7.8 instead of svn (and I have apologized for that) to back up your claim that I am an attention seeking idiot.

But I was right in the curl case and I am right here. I have tested my solutions and they both worked. I really have no idea what I have done that convinced you to look down at me as some mean person that is trying to make your life hard. All I want is to help, whether you believe that or not.

Also my curl suggestions to change the lines to:

install -v -d -m755 /usr/share/doc/curl-7.47.1 &&
cp -v -R docs/* /usr/share/doc/curl-7.47.1 &&
find /usr/share/doc/curl-7.47.1 \( -name Makefile\* \
-o -name \*.1 \
-o -name \*.3 \) \
-exec rm {} \; &&
rm -rf /usr/share/doc/curl-7.47.1/examples/.deps

would have worked, but as you insisted to do the cleanup in the source directory and not the destination, your final solution of:

cp -a docs docs-save       &&
rm -rf docs/examples/.deps &&

find docs \( -name Makefile\* \
          -o -name \*.1       \
          -o -name \*.3 \)    \
          -exec rm {} \;      &&
install -v -d -m755 /usr/share/doc/curl-7.47.1 &&
cp -v -R docs/*     /usr/share/doc/curl-7.47.1 &&

rm -rf docs &&
mv -i docs-save doc

must have taken you some extra time. But do you really also want to blame me for that? Or are you claiming that my solution does not work or causes any problems?

You can write me in personal, or on the list, if you wish that I should stop reporting any problems, I will of course follow this.

On a very last note: My use of the word "fuck" was in the context of me getting the feeling that I am told to "fuck off" by you. I did not throw this word at you.

comment:10 by Fernando de Oliveira, 6 years ago

Tim, I am sick today, all the day in bed, only worked for this ticket. Woke up minutes ago, and feeling better, must be a flu or some other minor virus.

Sorry for the delay.

I recognize I was unfair towards you. Apologies.

Please, keep coming with problems to better the book, either in the list or tickets. And thanks for doing that,

I did differently from what you suggest sometimes for simplicity, sometimes for we don't like to rewove things after installed, but before. You got a bonus there, the directory was clean as before.

For this vlc/lua, I did the tests using equations mostly like yours, but tried to simplify the ediyion.

As I am not very well, I left to test it again tomorrow morning.

Anyway, if you test what I did, it would be much helpful.

I was not feeling well since yesterday, thus, it may have facilitated my lack of objectivity, harming you.

Sorry again.

(Not re-reading). Going back to bed.

comment:11 by Tim Tassonis, 6 years ago

Ok, I will test it tomorrow. Get well soon.

comment:12 by Tim Tassonis, 6 years ago

I have now tested your MYCFLAGS solution, which is of course much cleaner and it seems to work well (no errors in vlc anymore).

It seems the shortest fix would be to just specify:

make MYCFLAGS="-DLUA_COMPAT_5_1" linux

as the Makefile already adds -DLUA_COMPAT_5_2. But that's totally irrelevant.

Cheers Tim

comment:13 by Fernando de Oliveira, 6 years ago

Ok. Thanks.

Note: See TracTickets for help on using tickets.