Opened 7 years ago

Closed 7 years ago

#7919 closed enhancement (fixed)


Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 7.10
Component: BOOK Version: SVN
Severity: normal Keywords:


Everything is dated 20160523.

Anybody using the binary will want to use gnupg2 (or gnupg1, which is looked for first) because that is now used to verify both the initial downloads and any updates later installed using tlmgr.

Phew! I just got my gcc-6.1 build ready in time :)

Change History (8)

comment:1 by ken@…, 7 years ago

Owner: changed from blfs-book@… to ken@…
Status: newassigned

comment:2 by ken@…, 7 years ago

Weirdness: attempting to download the binary via ftp at asked for a username and password, and failed (appeared to need a valid user/password - I had tried anon + my email). Same for texmf. But I got the source. Then I looked at the local ctan mirror (not yet up to date, and no source at all). Retried ftp from, got them all.

comment:3 by ken@…, 7 years ago

I've got a problem with the binary asy (at the moment I've only tested the binary versions). On BLFS-7.0 x86_64 with only vulnerability updates it works fine. But on recent svn with gcc-6.1 it craps out on the 'cylinder' test I added to my testfiles:


LaTeX Warning: File `cylinder-1+0_0.pdf' not found on input line 14.

! Package pdftex.def Error: File `cylinder-1+0_0.pdf' not found.

See the pdftex.def package documentation for explanation.
Type  H <return>  for immediate help.
l.14 ...-1+0_0.pdf}}}{\ASYprefix\jobname-1+0.prc}}

FWIW, line 14 of cylinder-1.tex (generated) is

\includemedia[noplaybutton,3Dlights=Headlamp,3Dmenu,3Dtoolbar=false,label=cylinder-1,3Daac=12.838470257,3Dc2w=0.624695048 -0.780868809 0 -0.178105069 -0.142484055 0.973641042 -0.760285921 -0.608228737 -0.228085776 1035.990105941 828.815129641 397.246811965,3Droo=1358.11888073,3Dpsob=H,3Dbg=1 1 1,add3Djscript=asylabels.js]{\phantom{\includegraphics[hiresbb]{\ASYprefix\jobname-1+0_0.pdf}}}{\ASYprefix\jobname-1+0.prc}}%

The prc file seems to be binary data. Boy, this texlive is fun.

comment:4 by ken@…, 7 years ago

I took a look at the output on 7.9 where it worked, and compared it to this one, but I'm none the wiser. So I tried building asy from source. The same problem. Because the binary needs ncurses5, freeglut, readline5 and everything works with gcc-5 I assume one of thos is being miscompiled by gcc-6.

comment:5 by ken@…, 7 years ago

I think I've succeeded, by adding -V to the asy invocation for the 3D test. Will do a clean install (I tried building asy separately) to confirm this.

comment:6 by ken@…, 7 years ago

Good news, just when I was getting ready to edit: an updated version of the source (20160523b) without the many unwanted extra files which slipped into the original release - so it should be much smaller.

I'm not sure if the patch will still be needed (I suspect it will be), nor if a fixed version of texmf with correct perms is going to appear.

comment:7 by ken@…, 7 years ago

And now a new 'b' texmf.

I'll get to this once I've managed to get through all of the biber deps (#8007) on the initial 2016 source and texmf.

comment:8 by ken@…, 7 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r17540

Note: See TracTickets for help on using tickets.