Opened 17 years ago

Closed 17 years ago

Last modified 8 years ago

#827 closed defect (fixed)

glib 1.2.10 w/gcc 3.4

Reported by: x_empt@… Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: ~CVS
Severity: normal Keywords: VERIFIED
Cc: bdubbs@…

Description

GCC 3.4 compiling glib 1.2.10 requires the following change.

+ GCC 3.4 and higher treats FUNCTION and similar special compiler + symbols as variables instead of macros. This means they no longer can + be concatenated directly with string literals. Unfortunately, GLIB uses + them in this way, so we have to disable this use with GCC 3.4 or higher. + + Index: glib.h + --- glib.h.orig 2001-02-27 04:44:38.000000000 +0100 + +++ glib.h 2004-04-28 10:24:56.000000000 +0200 + @@ -272,7 +272,7 @@ + /* Wrap the gcc PRETTY_FUNCTION and FUNCTION variables with + * macros, so we can refer to them as strings unconditionally. + */ + -#ifdef GNUC + +#if defined(GNUC) && (GNUC == 3 && GNUC_MINOR < 4) + #define G_GNUC_FUNCTION FUNCTION + #define G_GNUC_PRETTY_FUNCTION PRETTY_FUNCTION + #else /* __GNUC */

( source: http://cvs.openpkg.org/chngview?cn=16208 )

Change History (7)

comment:1 by jim@…, 17 years ago

Summary: glib 1.2.10 w/gcc 3.4 glib 1.2.10 w/gcc 3.4

comment:2 by x_empt@…, 17 years ago

Not mentioned in BLFS book. There will be no further updates to glib 1.2, so this probably needs to be listed as a patch in the book at: http://lfs.oregonstate.edu/blfs/view/cvs/general/glib.html

comment:3 by Randy McMurchy, 17 years ago

Cc: bdubbs@… added

comment:4 by Randy McMurchy, 17 years ago

* Bug 838 has been marked as a duplicate of this bug. *

comment:5 by Randy McMurchy, 17 years ago

Resolution: fixed
Status: newclosed

Added gcc34 patch to build instructions

comment:6 by igor@…, 16 years ago

Keywords: VERIFIED added

comment:7 by bdubbs@…, 8 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.