Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#9236 closed enhancement (fixed)

gnutls-3.5.12

Reported by: bdubbs@… Owned by: bdubbs@…
Priority: normal Milestone: 8.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (4)

comment:1 by bdubbs@…, 5 years ago

Owner: changed from blfs-book@… to bdubbs@…
Status: newassigned

comment:2 by bdubbs@…, 5 years ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 18724.

  • Version 3.5.12 (released 2017-05-11)
  • libgnutls: enabled TCP Fast open for MacOSX. Patch by Tim Ruehsen.
  • libgnutls: gnutls_x509_crt_check_hostname2() no longer matches IP addresses against DNS fields of certificate (CN or DNSname). The previous behavior was to tolerate some misconfigured servers, but that was non-standard and skipped any IP constraints present in higher level certificates.
  • libgnutls: when converting to IDNA2008, fallback to IDNA2003 (i.e., transitional encoding) if the domain cannot be converted. That provides maximum compatibility with browsers like firefox that perform the same conversion.
  • libgnutls: fix issue in RSA-PSK client callback which resulted in no username being sent to the peer. Patch by Nicolas Dufresne.
  • libgnutls: fix regression causing stapled extensions in trust modules not to be considered.
  • certtool: introduced the email_protection_key option. This option was introduced in documentation for certtool without an implementation of it. It is a shortcut for option 'key_purpose_oid = 1.3.6.1.5.5.7.3.4'.
  • certtool: made printing of key ID and key PIN consistent between certificates, public keys, and private keys. That is the private key printing now uses the same format as the rest.
  • gnutls-cli: introduced the --sni-hostname option. This allows overriding the hostname advertised to the peer.
  • API and ABI modifications: No changes since last version.

comment:3 by bdubbs@…, 5 years ago

Milestone: 8.1m8.1

Milestone renamed

comment:4 by bdubbs@…, 5 years ago

Milestone: m8.18.1

Milestone renamed

Note: See TracTickets for help on using tickets.