Opened 17 years ago

Closed 16 years ago

Last modified 13 years ago

#932 closed defect (fixed)

Incorrect GCC flags for Qt applications

Reported by: igor@… Owned by: bdubbs@…
Priority: high Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords: VERIFIED
Cc: Nico R., denis_trofimenko@…

Description

Change History (9)

comment:1 by denis_trofimenko@…, 17 years ago

Thank you Igor, for posting it here. I hope you don't mind I will post some info from dublicated bug, I opened, here and close my bug as dublication of this bug to keep blfs bugzilla clean?


So here some additional comments(some changes/additions to my email): Confirmation: To confirm the bug just look in mkspecs/linux-g++/qmake.conf for the value of QMAKE_INCDIR_QT and you will understand easie what I'm talking about. Problem description: If QT compiled using instructions of 1st method of the BOOK, after QT will be compiled successfully, you will get errors compiling QT applications against QT using qmake. Also qmake will be unable to find uic and some other binaries. Symptoms, for example /bin/uic: No such file or directory. qmake will pass -I/include flag to gcc instead of -I/usr/include/qt Solution: To fix the problem the one should use this sed script (you can change only in linux-g++ dir, but it doesn't hurt if you will fix for other compilers): for i in linux-{cxx,ecc-64,g++,g++-64,icc,kcc,kylix,pgcc} do sed -i -e 's:${QTDIR}/include:&/qt:' \

-e 's:${QTDIR}/lib:&/qt:' mkspecs/$i/qmake.conf

done Also, QTDIR variable should be set to QTDIR=/usr.

comment:2 by denis_trofimenko@…, 17 years ago

Cc: denis_trofimenko@… added

comment:3 by denis_trofimenko@…, 17 years ago

* Bug 934 has been marked as a duplicate of this bug. *

comment:4 by Nico R., 17 years ago

Cc: Nico R. added

comment:5 by bdubbs@…, 16 years ago

Status: newassigned

comment:6 by bdubbs@…, 16 years ago

Milestone: future6.1
Owner: changed from blfs-book@… to bdubbs@…
Status: assignednew

comment:7 by bdubbs@…, 16 years ago

Resolution: fixed
Status: newclosed

Added instructions to use QTDIR=/usr for Method 1 Also fixed the sed for qmake, but limited it to mkspecs/linux-g++/qmake.conf

comment:8 by tushar@…, 16 years ago

Keywords: VERIFIED added

comment:9 by (none), 13 years ago

Milestone: 6.1

Milestone 6.1 deleted

Note: See TracTickets for help on using tickets.