Opened 18 years ago

Closed 18 years ago

Last modified 8 years ago

#934 closed defect (duplicate)

Incorrect GCC flags for Qt applications

Reported by: denis_trofimenko@… Owned by: blfs-book@…
Priority: high Milestone:
Component: BOOK Version: ~CVS
Severity: major Keywords:
Cc:

Description

Confirmation: To confirm the bug just look in mkspecs/linux-g++/qmake.conf for the value of QMAKE_INCDIR_QT and you will understand easie what I'm talking about. Problem description: If QT compiled using instructions of 1st method of the BOOK, after QT will be compiled successfully, you will get errors compiling QT applications against QT using qmake. Also qmake will be unable to find uic and some other binaries. Symptoms, for example /bin/uic: No such file or directory. qmake will pass -I/include flag to gcc instead of -I/usr/include/qt Solution: To fix the problem the one should use this sed script (you can change only in linux-g++ dir, but it doesn't hurt if you will fix for other compilers): for i in linux-{cxx,ecc-64,g++,g++-64,icc,kcc,kylix,pgcc} do sed -i -e 's:${QTDIR}/include:&/qt:' \

-e 's:${QTDIR}/lib:&/qt:' mkspecs/$i/qmake.conf

done Also, QTDIR variable should be set to QTDIR=/usr.

Change History (3)

comment:1 by denis_trofimenko@…, 18 years ago

Summary: QT 1st method instructions errorIncorrect GCC flags for Qt applications

comment:2 by denis_trofimenko@…, 18 years ago

Resolution: duplicate
Status: newclosed

* This bug has been marked as a duplicate of 932 *

comment:3 by bdubbs@…, 8 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.