Opened 16 years ago

Closed 16 years ago

#1070 closed defect (invalid)

Glibc doesn't configure with autoconf version 2.13

Reported by: S_F_Sand@… Owned by: lfs-book@…
Priority: lowest Milestone:
Component: Book Version: 6.0
Severity: normal Keywords:
Cc:

Description

glibc-2.3.4-20040701 configure failed in pass 1 using autoconf 2.13. The error message refers to an undefined macro AC_FD_MSG. According to the autoconf documentation (section 15.6.1) this was fixed in autoconf 2.50.

The glibc INSTALL file says that you only need autoconf version 2.53 if you change configure.in. But autoconf is used early in the configure process (in directory sysdeps/i386/elf).

Change History (3)

comment:1 by bpotter@…, 16 years ago

Confirmed on debian 3.0 with autoconf 2.13 and autoconf 2.59 installed

A workaround is adding AC_PREREQ(2.50) to glibc-2.3.4-20040701/sysdeps/i386/elf/configure.in if you have autoconf > 2.5 installed

comment:2 by Matthew Burgess, 16 years ago

Is this still an issue with the released tarball used in the upcoming 6.1 book?

I think the configure scripts should already be generated and won't require

regenerating, but I'd appreciate confirmation.

comment:3 by Matthew Burgess, 16 years ago

Resolution: invalid
Status: newclosed

Based on a lack of response to comment 3, I'm assuming this is no longer an issue with the officially released tarball. Feel free to reopen if you can trigger the bug using the currently used version of glibc.

Note: See TracTickets for help on using tickets.