Opened 16 years ago

Closed 16 years ago

#1993 closed enhancement (fixed)

Linux-2.6.21.1

Reported by: Matthew Burgess Owned by: lfs-book@…
Priority: normal Milestone: Future
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

Change History (10)

comment:1 by alexander@…, 16 years ago

Milestone: 6.3Future

I propose that we ignore this release. Reason: stable LFS must be released with the kernel version which receives long-term bugfixes, and that's 2.6.20.x.

comment:2 by bryan@linuxfromscratch.org, 16 years ago

While that may be true, udev-109 (see #1992) logs an error with kernels older than 2.6.21 when it tries to run ata_id on libata disks. (See http://marc.info/?l=linux-hotplug-devel&m=117768109612881&w=2.)

I see a few different options:

1) Stay with udev-108 until either the patch is applied and a new version is released, or forever in the stable book (would depend on when the stable book gets frozen, and when (and whether) the patch gets applied to udev).

2) Upgrade to udev-109 and apply the patch ourselves (until it gets applied upstream -- if it gets applied upstream -- and we upgrade to whatever version has it).

3) Upgrade the kernel.

Neither 1) nor 2) will give us compatibility symlinks (so I believe the comment in the book sources saying that "by-id will even survive the transition to libata" would be incorrect, though I'm not sure). Plus I'm not sure why 2.6.21 won't receive long-term bugfixes; isn't it the new stable kernel? (I have no idea whether it is or not; all I know is the past behavior of the kernel -stable people w.r.t. releases. Maybe that's going to change this time around.)

OTOH, it could perhaps be argued that libata is way beyond LFS -- at least, until it becomes the default in the kernel configuration. (If it becomes the default. I'm guessing it'll get a lot more testing before they do that.)

Of course, I'd agree that we should skip 2.6.21 if we want to get 6.3 out the door "soon" (depending on what exactly "soon" means). And udev-109 may not really be required either; the only changes that sound like they would be good to have are the ones that fix bugs ("create_path: don't fail if something else created the directory" and "udevd: fix serialization of events").

in reply to:  1 comment:3 by Matthew Burgess, 16 years ago

Replying to alexander@linuxfromscratch.org:

I propose that we ignore this release. Reason: stable LFS must be released with the kernel version which receives long-term bugfixes, and that's 2.6.20.x.

I assume that by long-term bugfixes, you're referring to Adrian Bunk's tree? I didn't know he was planning on taking over the 2.6.20 line. To be honest, I'd rather upgrade both Udev and Linux. The stable maintainers will still look after 2.6.21 for us, so it's not like we're going to be stuck with a potentially buggy/insecure kernel.

comment:4 by alexander@…, 16 years ago

Summary: Linux-2.6.21Linux-2.6.21.1

Yes, I am referring to Adrian Bunk's tree. The stable maintainers will stop looking after 2.6.21 as soon as 2.6.22 is out.

comment:5 by dnicholson@…, 16 years ago

Sorry to be a n00b on this, but does he maintain the even numbered releases, or just selected ones?

comment:6 by alexander@…, 16 years ago

Only selected ones

in reply to:  2 ; comment:7 by Matthew Burgess, 16 years ago

Replying to Bryan Kadzban:

While that may be true, udev-109 (see #1992) logs an error with kernels older than 2.6.21 when it tries to run ata_id on libata disks. (See http://marc.info/?l=linux-hotplug-devel&m=117768109612881&w=2.)

That patch has now been applied (see http://marc.info/?l=linux-hotplug-devel&m=117779861106697&w=2). So, I think it's safe to upgrade the kernel once a new Udev version has been released.

Alex, I think it was a coincidence of timing that we ended up releasing LFS-6.2 with what would end up being a long-term maintained kernel. In general, we try to keep up with the latest upstream releases so that if folks need to report bugs they're doing so with against recent sources. The kernel development cycle seems to be tracking regression reports more closely now and feeding patches for them to the stable team (see http://www.ussg.iu.edu/hypermail/linux/kernel/0704.3/2674.html).

in reply to:  7 comment:8 by bryan@linuxfromscratch.org, 16 years ago

Replying to matthew@linuxfromscratch.org:

That patch has now been applied (see http://marc.info/?l=linux-hotplug-devel&m=117779861106697&w=2). So, I think it's safe to upgrade the kernel once a new Udev version has been released.

And -110 has been released today, with the patch included. (I've just updated #1992.)

comment:9 by alexander@…, 16 years ago

I'd wait for 2.6.21.2, for sis900 network card fix that affects at least one person on lfs-support

comment:10 by Matthew Burgess, 16 years ago

Resolution: fixed
Status: newclosed

Fixed in r8111.

Note: See TracTickets for help on using tickets.