Opened 3 years ago

Closed 3 years ago

#4400 closed task (fixed)

gzip-1.10

Reported by: Bruce Dubbs Owned by: lfs-book
Priority: normal Milestone: 8.4
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (2)

comment:1 by Bruce Dubbs, 3 years ago

  • Noteworthy changes in release 1.10 (2018-12-29) [stable]

Changes in behavior

Compressed gzip output no longer contains the current time as a timestamp when the input is not a regular file. Instead, the output contains a null (zero) timestamp. This makes gzip's behavior more reproducible when used as part of a pipeline. (As a reminder, even regular files will use null timestamps after the year 2106, due to a limitation in the gzip format.)

Bug fixes

A use of uninitialized memory on some malformed inputs has been fixed. [bug present since the beginning]

A few theoretical race conditions in signal handers have been fixed. These bugs most likely do not happen on practical platforms. [bugs present since the beginning]

comment:2 by Bruce Dubbs, 3 years ago

Resolution: fixed
Status: newclosed

Fixed at revision 11498.

Note: See TracTickets for help on using tickets.