Opened 2 years ago

Closed 2 years ago

#4498 closed task (fixed)

binutils-2.32 gold testsuite linker error

Reported by: ken@… Owned by: lfs-book
Priority: normal Milestone: 9.0
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

Ben Brian mentioned this last week (archive http://lists.linuxfromscratch.org/pipermail/lfs-dev/2019-July/073178.html

"While testing binutils-2.32 in Ch 6.16 of LFS-BOOK-20190624-systemd, I receive this error in the gold testsuite:

gcctestdir/collect-ld: internal error in set_section_addresses, at ../../gold/output.cc:4441 collect2: error: ld returned 1 exit status make[5]: * [Makefile:9430: incremental_copy_test] Error 1

This was reported upstream as a binutils + gcc-9.x bug: https://sourceware.org/bugzilla/show_bug.cgi?id=24123

The error prevents the full testsuite from running. The following workaround (after extracting binutils) disables the test and prevents the error on my system:

sed -i.orig -e '/@\tincremental_copy_test$(EXEEXT)
/d' \

-e '/@\tincremental_copy_test
/d' \ gold/testsuite/Makefile.in"

He also attached a much fuller patch as an alternative, to remove all traces of incremental_copy_test.

I've now confirmed that on my (somewhat older) gcc-9.1 builds the problem is indeed present. Usually I just look for 'FAIL' in the output, so it is easy to miss this.

I have not confirmed the fix at this point (still exploring older systems using gcc-8.3.0), but best to flag this up so it doesn't get overlooked.

Change History (2)

comment:1 by Bruce Dubbs, 2 years ago

Confirmed.

I am adding:

Now remove one test that prevents the tests from running
to completion:

sed -i '/@\tincremental_copy/d' gold/testsuite/Makefile.in

The tests no have one additional failure. The results are now:

"The PC-relative offset test is known to fail. The debug_msg.sh is known to fail in the LFS environment."

comment:2 by Bruce Dubbs, 2 years ago

Resolution: fixed
Status: newclosed

Fixed at revision 11639.

Note: See TracTickets for help on using tickets.