#4553 closed task (fixed)

elfutils-0.178

Reported by: Bruce Dubbs Owned by: lfs-book
Priority: normal Milestone: 9.1
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (5)

comment:1 by Bruce Dubbs, 22 months ago

Version 0.178

debuginfod: New server, client tool and library to index and fetch ELF/DWARF files addressed by build-id through HTTP.

doc: There are now some manual pages for functions and tools.

backends: The libebl libraries are no longer dynamically loaded through dlopen, but are now compiled into libdw.so directly.

readelf: -n, --notes now takes an optional "SECTION" argument. -p and -x now also handle section numbers. New option --dyn-sym to show just the dynamic symbol table.

libcpu: Add RISC-V disassembler.

libdw: Abbrevs and DIEs can now be read concurrently by multiple threads through the same Dwarf handle.

libdwfl: Will try to use debuginfod when installed as fallback to retrieve ELF and DWARF debug data files by build-id.

comment:2 by thomas, 22 months ago

On a i686 system i needed to add --disable-debuginfod otherwise configure failed:

...
configure: checking debuginfod dependencies, disable to skip
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for libmicrohttpd... no
checking for libcurl... yes
checking for sqlite3... yes
checking for libarchive... yes
configure: error: C++ compiler or dependencies not found, use --disable-debuginfod to disable.

Not tested on x86_64 yet. (Btw, curl, sqlite3 and libarchive are on host system, found just while reproducing the error message on the host which is also a LFS-9.0 based i686 machine; of course, all three tests gives 'no' on newly built LFS system)

Last edited 22 months ago by thomas (previous) (diff)

comment:3 by thomas, 22 months ago

Looks like the error "C++ compiler or dependencies not found" is somewhat misleading. Its according to the config.log caused by the absence of libmicrohttpd. So, it doesn't have to do with C++ but with deps on libmicrohttpd, libcur, sqlite3 or libarchive...

comment:4 by Bruce Dubbs, 22 months ago

I am adding --disable-debuginfod. Initial tests are OK, but I also had to add a LS_LIBRARY_PATH for one test to pass.

This will be fixed no later than tomorrow. (Dec 1)

Version 0, edited 22 months ago by Bruce Dubbs (next)

comment:5 by Bruce Dubbs, 22 months ago

Resolution: fixed
Status: newclosed

Fixed at revision 11702.

Note: See TracTickets for help on using tickets.