#4705 closed task (fixed)

bc-3.1.5

Reported by: Bruce Dubbs Owned by: lfs-book
Priority: normal Milestone: 10.0
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

# 3.1.4

This is a production release that fixes one bug, changes two behaviors, and removes one environment variable.

The bug is like the one in the last release except it applies if files are being executed. I also made the fix more general.

The behavior that was changed is that bc now exits when given -e, -f, --expression or --file. However, if the last one of those is -f- (using stdin as the file), bc does not exit. If -f- exists and is not the last of the -e and -f options (and equivalents), bc gives a fatal error and exits.

Next, I removed the BC_EXPR_EXIT and DC_EXPR_EXIT environment variables since their use is not needed with the behavior change.

Finally, I made it so bc does not print the header, though the -q and --quiet options were kept for compatibility with GNU bc.

Change History (2)

comment:1 by Bruce Dubbs, 12 months ago

Summary: bc-3.1.4bc-3.1.5

Now version 3.1.5

This is a production release that fixes the Chinese locales (which caused bc to crash) and a crash caused by bc executing code when it should not have been able to.

comment:2 by Bruce Dubbs, 12 months ago

Resolution: fixed
Status: newclosed

fixed at revision 12011.

Note: See TracTickets for help on using tickets.