#4735 closed task (fixed)

libcap-2.44

Reported by: Bruce Dubbs Owned by: lfs-book
Priority: normal Milestone: 10.1
Component: Book Version: SVN
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (3)

comment:1 by Pierre Labastie, 10 months ago

Heads-up: commit 91fc109c64 has again changed the Makefile for library installation. I think the "sed" will need to be adjusted again. Or maybe, just use make install-shared and no sed. The problem is that in this case, libpsx, which is only static, is not installed. If we want it, it looks like make install-static-psx would do.

comment:2 by Xi Ruoyao, 10 months ago

To install libcap.so, along with its header /usr/include/sys/capability.h:

make -C libcap lib=lib PKGCONFIGDIR=/usr/lib/pkgconfig install-shared-cap

To install capsh, getcap, getpcaps, and setcap:

make -C progs install

To install man pages:

make -C doc install

To (optionally) install libpsx.a, and its header psx_syscall.h:

make -C libcap lib=lib PKGCONFIGDIR=/usr/lib/pkgconfig install-psx

comment:3 by Bruce Dubbs, 10 months ago

Resolution: fixed
Status: newclosed

Fixed at revision 12053.

Note: See TracTickets for help on using tickets.