Opened 2 months ago

Closed 8 weeks ago

#4859 closed enhancement (fixed)

kmod-29

Reported by: Bruce Dubbs Owned by: lfs-book
Priority: normal Milestone: 11.0
Component: Book Version: git
Severity: normal Keywords:
Cc:

Description

New version.

Change History (2)

comment:1 by Bruce Dubbs, 8 weeks ago

kmod 29

Improvements

  • Add support to use /usr/local as a place for configuration files. This makes it easier to install locally without overriding distro files.

Bug fixes

  • Fix modinfo -F when module is builtin: when we asked by a specific field from modinfo, it was not working correctly if the module was builtin
  • Documentation fixes on precedence order of /etc and /run: the correct order is /etc/modprobe.d, /run/modprobe.d, /lib/modprobe.d
  • Fix the priority order that we use for searching configuration files. The correct one is /etc, /run, /usr/local/lib, /lib, for both modprobe.d and depmo.d
  • Fix kernel command line parsing when there are quotes present. Grub mangles the command line and changes it from 'module.option="val with spaces"' to '"module.option=val with spaces"'. Although this is weird behavior and grub could have been fixed, the kernel understands it correctly for builtin modules. So change libkmod to also parse it correctly. This also brings another hidden behavior from the kernel: newline in the kernel command line is also allowed and can be used to separate options.
  • Fix a memory leak, overflow and double free on error path
  • Fix documentation for return value from kmod_module_get_info(): we return the number of entries we added to the list
  • Fix output of modules.builtin.alias.bin index: we were writing an empty file due to the misuse of kmod_module_get_info()

Infra/internal

  • Retire integration with semaphoreci
  • Declare the github mirror also as an official upstream source: now besides accepting patches via mailing list, PRs on github are also acceptable
  • Misc improvements to testsuite, so we can use it reliably regardless of the configuration used: now tests will skip if we don't have the build dependencies)

comment:2 by Bruce Dubbs, 8 weeks ago

Resolution: fixed
Status: newclosed

Fixed at af4f4bfa8ccaa4e88bbe8bc13a17f7e3240a5cb6

Package updates.
    Update to iana-etc-20210526.
    Update to vim-8.2.2890.
    Update to zstd-1.5.0.
    Update to perl-5.34.0.
    Update to inux-5.12.7.
    Update to libcap-2.50.
    Update to kmod-29.
    Update to expat-2.4.1.
    Update to elfutils-0.185.
    Update to bc-4.0.2.
Note: See TracTickets for help on using tickets.