Opened 6 months ago

Closed 5 months ago

#4875 closed enhancement (fixed)

Fix gcc-11.1.0 regressions before our 11.0 release

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 11.0
Component: Book Version: git
Severity: normal Keywords:
Cc:

Description

As I noted in https://lists.linuxfromscratch.org/sympa/arc/lfs-dev/2021-06/msg00055.html there are some regressions in gcc-11.1.0 which it would be nice to fix before our 11.0 release (all these are for g++).

https://gcc.gnu.org/PR100644 to allow firefox >= 89.0 to be built with g++

https://gcc.gnu.org/PR100489 an ICE.

https://gcc.gnu.org/PR100102 another ICE.

Those two ICEs are not common, but neither was the problem which caused the firefox build to fail, and they are all regressions.

If anybody has any other fixes for gcc which they think should be applied, please mention them in the next couple of days.

Change History (3)

comment:1 by ken@…, 5 months ago

I'll take this when I've got to the end of chapter 8, to check all test resluts before I add the patch.

comment:2 by ken@…, 5 months ago

Owner: changed from lfs-book to ken@…
Status: newassigned

Jean-Marc Pigeon has now reported that gcc's bootstrap against kernel 5.13.0 header fails because cyclades.h has been removed. See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=100379, fix is https://gcc.gnu.org/git/?p=gcc.git;a=patch;h=2bf34b9f4e446bf9be7f04458058dd5319fb396e Adding to the existing patches.

comment:3 by ken@…, 5 months ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.