Opened 4 months ago

Closed 3 months ago

#4938 closed enhancement (fixed)

python-3.10.0

Reported by: Bruce Dubbs Owned by: lfs-book
Priority: normal Milestone: 11.1
Component: Book Version: git
Severity: normal Keywords:
Cc:

Description

New minor version.

Change History (2)

comment:1 by Bruce Dubbs, 3 months ago

What's New in Python 3.10.0 final?

*Release date: 2021-10-04*

Core and Builtins

  • bpo-45121: Fix issue where Protocol.__init__ raises RecursionError when it's called directly or via super().

Library

  • bpo-45234: Fixed a regression in :func:~shutil.copyfile, :func:~shutil.copy, :func:~shutil.copy2 raising :exc:FileNotFoundError when source is a directory, which should raise :exc:IsADirectoryError

Documentation

  • bpo-45216: Remove extra documentation listing methods in difflib. It was rendering twice in pydoc and was outdated in some places.
  • bpo-45024: :mod:collections.abc documentation has been expanded to explicitly cover how instance and subclass checks work, with additional doctest examples and an exhaustive list of ABCs which test membership purely by presence of the right :term:special method\s.

Tests

  • bpo-45128: Fix test_multiprocessing_fork failure due to test_logging and sys.modules manipulation.
  • bpo-44860: Update test_sysconfig.test_user_similar() for the posix_user scheme: platlib doesn't use :data:sys.platlibdir.

Build

  • bpo-45067: The ncurses function extended_color_content was introduced in 2017

(https://invisible-island.net/ncurses/NEWS.html#index-t20170401). The ncurses-devel package in CentOS 7 had a older version ncurses resulted in compilation error. For compiling ncurses with extended color support, we verify the version of the ncurses library >= 20170401.

IDLE

  • bpo-45193: Make completion boxes appear on Ubuntu again.

C API

  • bpo-45307: Restore the private C API function :func:_PyImport_FindExtensionObject. It will be removed in Python 3.11.

See tarfile::Python-3.10.0/Misc/NEWS for release candidate and beta changes (about 5000 lines of changes).

comment:2 by Bruce Dubbs, 3 months ago

Resolution: fixed
Status: newclosed

Fixed at commit fa32551de1d77a763a247b4c704bd860a3d5c8a0

Package updates.
    Update to vim-8.2.3508.
    Update to tzdata-2021c.
    Update to Python-3.10.0.
    Update to Jinja2-3.0.2.
    Update to linux-5.14.12.
    Update to iana-etc-20211004.
    Update to bc-5.1.1.
    Update to automake-1.16.5.
Note: See TracTickets for help on using tickets.