Opened 4 years ago

Closed 4 years ago

#10272 closed enhancement (fixed)

gjs-1.50.3

Reported by: bdubbs@… Owned by: blfs-book@…
Priority: normal Milestone: 8.2
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (2)

comment:1 by bdubbs@…, 4 years ago

Version 1.50.3

GJS will now log a warning when a GObject is accessed in Javascript code after the underlying object has been freed in C. (This used to work most of the time, but crash unpredictably.) We now prevent this situation which, is usually caused by a memory management bug in the underlying C library.

Closed bugs and merge requests:

  • Add checks for GObjects that have been finalized [#21, #23, !25, !28, !33, Marco Trevisan]
  • Test "Cairo context has methods when created from a C function" fails [#27, !35, Valentín Barros]
  • Various fixes from the master branch for rare crashes [Philip Chimento]

comment:2 by bdubbs@…, 4 years ago

Resolution: fixed
Status: newclosed

Fixed at revision 19680.

Note: See TracTickets for help on using tickets.