Opened 3 years ago

Closed 3 years ago

#10815 closed defect (worksforme)

Libdv-1.0.0 will not compile

Reported by: christopher Owned by: blfs-book
Priority: highest Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

I posted this on the mailing list and no one has even bothered replying. It seems that the quality of the book is deteriorating at an alarming rate. This library is listed in the book, and has had no upstream activity since at least 2009. If no one can find a fix for it, then it should be removed from the book as it is useless to keep it there broken.

For some reason libdv-1.0.0 will not compile for me. I have checked the patches at debian and not even with the patches applied will it compile successfully.

The error I am getting is:

encode.c:1505:2: note: within this loop

for (;i < 16; i++) {

mv -f .deps/encode.Tpo .deps/encode.Plo /bin/sh ../libtool --silent --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -g -O2 -Wall -g -MT headers.lo -MD -MP -MF .deps/headers.Tpo -c -o headers.lo headers.c mv -f .deps/headers.Tpo .deps/headers.Plo /bin/sh ../libtool --silent --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -g -O2 -Wall -g -MT enc_input.lo -MD -MP -MF .deps/enc_input.Tpo -c -o enc_input.lo enc_input.c enc_input.c:1021:36: error: ‘VIDEO_MAX_FRAME’ undeclared here (not in a function); did you mean ‘VIDEO_MODE_SECAM’?

static struct video_mmap gb_frames[VIDEO_MAX_FRAME];

VIDEO_MODE_SECAM

enc_input.c:1021:26: warning: ‘gb_frames’ defined but not used [-Wunused-variable]

static struct video_mmap gb_frames[VIDEO_MAX_FRAME];

Christopher

Change History (2)

comment:1 by ken@…, 3 years ago

First, not everybody sees your mails - I suspect that something in your mails triggers an "odd" response from _my_ isp's mailserver - occasionally your mails come through, other times not. http://lists.linuxfromscratch.org/pipermail/blfs-dev/2018-May/034595.html

Second, Wayne did reply. http://lists.linuxfromscratch.org/pipermail/blfs-dev/2018-May/034600.html - that sounds as if the problem is your end. A quick test shows it builds for me on a system from just over a month ago.

Third, unless you are commenting on recent changes, the support list might be better. Yes, I know it is sometimes hard to know if -support or -dev is more appropriate.

comment:2 by Bruce Dubbs, 3 years ago

Resolution: worksforme
Status: newclosed

Built fine with gcc8 on May 15 for me.

Note: See TracTickets for help on using tickets.