Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#10816 closed defect (worksforme)

Bind Utilities-9.12.1 will not build

Reported by: christopher Owned by: blfs-book
Priority: high Milestone: 8.3
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Hello,

I do not seem to be having a good time with things so far. Now when attempting to build bind utilities-9.12.1 I am getting the below error. Please note that I have tried the earlier release in the stable-systemd book and get exactly the same results. I have no idea if gcc is the issue, or if some other newer library is causing this. It makes no sense to me. I have recompiled json-c and installed jsoncpp and still get the same results. Even tried the version of json-c in the stable book with the same version of bind and no change.

making all in /opt/sources/bind-9.12.1/lib/dns/include/dst make[2]: Entering directory '/opt/sources/bind-9.12.1/lib/dns/include/dst' make[2]: Leaving directory '/opt/sources/bind-9.12.1/lib/dns/include/dst' make[1]: Leaving directory '/opt/sources/bind-9.12.1/lib/dns/include' gcc -I/opt/sources/bind-9.12.1 -I../.. -I. -I../../lib/dns -Iinclude -I/opt/sources/bind-9.12.1/lib/dns/include -I../../lib/dns/include -I/opt/sources/bind-9.12.1/lib/isc/include -I../../lib/isc -I../../lib/isc/include -I../../lib/isc/unix/include -I../../lib/isc/pthreads/include -I../../lib/isc/x86_32/include -I/usr/include -D_REENTRANT -DUSE_MD5 -DOPENSSL -DGSSAPI -DUSE_ISC_SPNEGO -D_GNU_SOURCE -g -O2 -I/usr/include/libxml2 -fPIC -W -Wall -Wmissing-prototypes -Wcast-qual -Wwrite-strings -Wformat -Wpointer-arith -fno-strict-aliasing -fno-delete-null-pointer-checks -c acl.c In file included from /usr/include/json/autolink.h:9:0,

from /usr/include/json/json.h:9, from /opt/sources/bind-9.12.1/lib/isc/include/isc/json.h:33, from /opt/sources/bind-9.12.1/lib/isc/include/isc/mem.h:16, from acl.c:13:

/usr/include/json/config.h:9:10: fatal error: string: No such file or directory

#include <string> typedef String

~

compilation terminated. make: * [Makefile:325: acl.o] Error 1 make: Leaving directory '/opt/sources/bind-9.12.1/lib/dns'

Regards,

Christopher.

Change History (2)

comment:1 by Bruce Dubbs, 3 years ago

Resolution: worksforme
Status: newclosed

((( /usr/include/c++/8.1.0/debug/string /usr/include/c++/8.1.0/string /usr/include/c++/8.1.0/experimental/string }}}

Looks line g++ is not installed properly.

Installed fine for me on May 17 with gcc8. Use blfs-support instead of the ticket system.

in reply to:  description comment:2 by ken@…, 3 years ago

Replying to cjg:

Bruce has closed this while I was writing, but some further comments:

/usr/include/json/config.h:9:10: fatal error: string: No such file or directory

#include <string> typedef String

~

looks, on the face of it, like https://github.com/intel-iot-devkit/mraa/issues/799 and the reply on that was "The problem is that /usr/include/json and /usr/include/json-c both contain a file called json.h which is used by your cmake scripts to find the right folder. The former belongs to a json c++ library. The latter is the json C library.". I doubt that bind-utils is using cmake, but I suspect you have installed jsoncpp and bind-utils is finding that ?

If not, which package provided /usr/include/json/config.h ? None of my builds in the last 5 years seem to have installed that file.

I see you have -DGSSAPI so your build is different from my (sysv) build, but this looks to me like another example of "when it breaks, you get to keep both pieces". And yes, this definitely belongs on blfs-support.

Note: See TracTickets for help on using tickets.