Opened 4 years ago

Closed 4 years ago

#11175 closed enhancement (fixed)

mesa-18.2.2

Reported by: Bruce Dubbs Owned by: Douglas R. Reno
Priority: normal Milestone: 8.4
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version.

Change History (3)

comment:1 by Douglas R. Reno, 4 years ago

Owner: changed from blfs-book to Douglas R. Reno
Status: newassigned

Fetching everything that I know I'll get to in the next few days, per Bruce

comment:2 by Douglas R. Reno, 4 years ago

Summary: mesa-18.2.1mesa-18.2.2

Now version 18.2.2 (as of today)

18.2.1:

New features

None
Bug fixes

    Bug 103241 - Anv crashes when using 64-bit vertex inputs
    Bug 107280 - [DXVK] Batman: Arkham City with tessellation enabled hangs on SKL GT4
    Bug 107772 - Mesa preprocessor matches if(def)s & endifs incorrectly
    Bug 107779 - Access violation with some games
    Bug 107810 - The 'va_end' call is missed after 'va_copy' in 'util_vsnprintf' function under windows
    Bug 107832 - Gallium picking A16L16 formats when emulating INTENSITY16 conflicts with mesa
    Bug 107843 - 32bit Mesa build failes with meson.
    Bug 107879 - crash happens when link program
    Bug 107891 - [wine, regression, bisected] RAGE, Wolfenstein The New Order hangs in menu

Changes

Andres Gomez (3):

    docs: add sha256 checksums for 18.2.0
    Revert "Revert "glsl: skip stringification in preprocessor if in unreachable branch""
    cherry-ignore: i965/tools: 32bit compilation with meson

Andrii Simiklit (4):

    apple/glx/log: added missing va_end() after va_copy()
    mesa/util: don't use the same 'va_list' instance twice
    mesa/util: don't ignore NULL returned from 'malloc'
    mesa/util: add missing va_end() after va_copy()

Bas Nieuwenhuizen (5):

    radv: Support v3 of VK_EXT_vertex_attribute_divisor.
    radv: Set the user SGPR MSB for Vega.
    radv: Only allow 16 user SGPRs for compute on GFX9+.
    radv: Use build ID if available for cache UUID.
    radv: Fix driver UUID SHA1 init.

Christopher Egert (1):

    radeon: fix ColorMask

Dave Airlie (1):

    virgl: don't send a shader create with no data. (v2)

Dylan Baker (1):

    meson: Print a message about why a libdrm version was selected

Eric Anholt (2):

    v3d: Fix SRC_ALPHA_SATURATE blending for RTs without alpha.
    v3d: Fix setup of the VCM cache size.

Erik Faye-Lund (2):

    winsys/virgl: avoid unintended behavior
    virgl: adjust strides when mapping temp-resources

Fritz Koenig (2):

    mesa: Additional FlipY applications
    mesa: FramebufferParameteri parameter checking

Gert Wollny (2):

    winsys/virgl: correct resource and handle allocation (v2)
    mesa/texture: Also check for LA texture when querying intensity component size

Ian Romanick (1):

    i965/fs: Don't propagate conditional modifiers from integer compares to adds

Jason Ekstrand (11):

    anv/pipeline: Only consider double elements which actually exist
    i965: Workaround the gen9 hw astc5x5 sampler bug
    anv: Re-emit vertex buffers when the pipeline changes
    anv: Disable the vertex cache when tessellating on SKL GT4
    anv: Clamp scissors to the framebuffer boundary
    vulkan: Update the XML and headers to 1.1.84
    anv: Support v3 of VK_EXT_vertex_attribute_divisor
    anv/query: Write both dwords in emit_zero_queries
    nir: Add a small pass to rematerialize derefs per-block
    nir/loop_unroll: Re-materialize derefs in use blocks before unrolling
    nir/opt_if: Re-materialize derefs in use blocks before peeling loops

Josh Pieper (1):

    st/mesa: Validate the result of pipe_transfer_map in make_texture (v2)

Juan A. Suarez Romero (2):

    cherry-ignore: radv: fix descriptor pool allocation size
    Update version to 18.2.1

Kenneth Feng (1):

    amd: Add Picasso device id

Marek Olšák (5):

    radeonsi: fix HTILE for NPOT textures with mipmapping on SI/CI
    winsys/radeon: fix CMASK fast clear for NPOT textures with mipmapping on SI/CI
    r600: fix HTILE for NPOT textures with mipmapping
    radeonsi: fix printing a BO list into ddebug reports
    ac: revert new LLVM 7.0 behavior for fdiv

Mathias Fröhlich (1):

    tnl: Fix green gun regression in xonotic.

Mauro Rossi (3):

    android: broadcom/genxml: fix collision with intel/genxml header-gen macro
    android: broadcom/cle: add gallium include path
    android: broadcom/cle: export the broadcom top level path headers

Michel Dänzer (1):

    loader/dri3: Only wait for back buffer fences in dri3_get_buffer

Pierre Moreau (1):

    nvir: Always split 64-bit IMAD/IMUL operations

Samuel Pitoiset (7):

    radv: fix function names for VK_EXT_conditional_rendering
    radv: fix VK_EXT_conditional_rendering visibility
    radv: bump the maximum number of arguments to 64
    radv: handle loc->indirect correctly for the first descriptor
    radv: fix GPU hangs with 32-bit indirect descriptors
    radv: fix flushing indirect descriptors
    radv: fix setting global locations for indirect descriptors

Sergii Romantsov (3):

    intel: compiler option msse2 and mstackrealign
    i965/tools: 32bit compilation with meson
    mesa/meson: 32bit xmlconfig linkage

Timothy Arceri (2):

    glsl: fixer lexer for unreachable defines
    Revert "radeonsi: avoid syncing the driver thread in si_fence_finish"

18.2.2:

New features

None
Bug fixes

    Bug 104602 - [apitrace] Graphical artifacts in Civilization VI on RX Vega
    Bug 104926 - swrast: Mesa 17.3.3 produces: HW cursor for format 875713089 not supported
    Bug 107276 - radv: OpBitfieldUExtract returns incorrect result when count is zero
    Bug 107786 - [DXVK] MSAA reflections are broken in GTA V
    Bug 108024 - [Debian Stretch]Fail to build because "xcb_randr_lease_t"

Changes

Alex Deucher (1):

    pci_ids: add new polaris pci id

Andres Rodriguez (1):

    radv: only emit ZPASS_DONE for timestamp queries on gfx queues

Axel Davy (3):

    st/nine: Clamp RCP when 0*inf!=0
    st/nine: Avoid redundant SetCursorPos calls
    st/nine: Increase maximum number of temp registers

Dylan Baker (1):

    meson: Don't compile pipe loader with dri support when not using dri

Eric Anholt (1):

    vc4: Fix sin(0.0) and cos(0.0) accuracy to fix SDL rendering rotation.

Eric Engestrom (1):

    vulkan/wsi/display: check if wsi_swapchain_init() succeeded

Jason Ekstrand (1):

    anv,radv: Implement vkAcquireNextImage2

Juan A. Suarez Romero (2):

    docs: add sha256 checksums for 18.2.1
    Update version to 18.2.2

Leo Liu (1):

    radeon/uvd: use bitstream coded number for symbols of Huffman tables

Marek Olšák (2):

    glsl_to_tgsi: invert gl_SamplePosition.y for the default framebuffer
    radeonsi: NaN should pass kill_if

Maxime (1):

    vulkan: Disable randr lease for libxcb < 1.13

Michal Srb (1):

    st/dri: don't set queryDmaBufFormats/queryDmaBufModifiers if the driver does not implement it

Rhys Perry (2):

    nvc0: Update counter reading shaders to new NVC0_CB_AUX_MP_INFO
    nvc0: fix bindless multisampled images on Maxwell+

Samuel Iglesias Gonsálvez (1):

    anv: Add support for protected memory properties on anv_GetPhysicalDeviceProperties2()

Samuel Pitoiset (1):

    radv: use the resolve compute path if dest uses multiple layers

Stuart Young (1):

    docs: Update FAQ with respect to s3tc support

Timothy Arceri (1):

    radeonsi: add a workaround for bitfield_extract when count is 0

And with this update, we have support for the new AMD Polaris-series cards!

comment:3 by Douglas R. Reno, 4 years ago

Resolution: fixed
Status: assignedclosed

Fixed at r20582

Note: See TracTickets for help on using tickets.