Opened 4 years ago

Closed 4 years ago

#11176 closed enhancement (fixed)

rustc : point it to system ssh2 when installing cairo

Reported by: ken@… Owned by: ken@…
Priority: normal Milestone: 8.4
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Looking back at my notes, I've had intermittent problems with the build or pre-install failing to find libssh2. This week I've repeatedly had the pre-install (i.e. the final compiles) failing in cargo because it could not find libcrmf.a. And yet the same scripts on a different machine, both running 8.3, were fine.

Tried reverting to python2, no change. Tried installing static libcrmf - found it but failed to link (not built for -fPIE).

Googling re cargo rather than rust, I eventually found https://github.com/alexcrichton/ssh2-rs/issues/91. One comment mentioned setting LIBSSH2_SYS_USE_PKG_CONFIG=1. I've now exported that in the command to do the install, and succeeded.

Change History (2)

comment:1 by ken@…, 4 years ago

Owner: changed from blfs-book to ken@…
Status: newassigned

comment:2 by ken@…, 4 years ago

Resolution: fixed
Status: assignedclosed
Note: See TracTickets for help on using tickets.