#12554 closed enhancement (fixed)

gdb-8.3.1

Reported by: Douglas R. Reno Owned by: Bruce Dubbs
Priority: normal Milestone: 9.1
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

New point version

Change History (3)

comment:1 by Bruce Dubbs, 22 months ago

Owner: changed from blfs-book to Bruce Dubbs
Status: newassigned

comment:2 by Bruce Dubbs, 22 months ago

The latest version of GDB, version 8.3.1, is available for download.

This is a minor corrective release over GDB 8.3, fixing the following issues:

  • PR c++/20020 (GDB segfault on printing objects)
  • PR gdb/24454 (nat/x86-linux-dregs.c:146: internal-error: void x86_linux_update_debug_registers(lwp_info*): Assertion `lwp_is_stopped (lwp)' failed)
  • PR breakpoints/24541 (Incorrect evaluation of systemtap probes due to register being signed and probe expression assuming unsigned)
  • PR symtab/24545 (Symbol loading performance regression with cc1)
  • PR gdb/24592 (amd64->i386 linux syscall restart problem)
  • PR gdb/25009 (terminate called after throwing an instance of 'srchilite::ParserException')
  • PR gdb/25010 (Calls to error () can cause SIGTTOU to send gdb to the background)
  • PR breakpoints/25011 (Breakpoints on file reloads broken for PIE binaries)

This corrective release also brings the following testsuite fixes and enhancements:

  • PR testsuite/25005 (gdb-caching-proc.exp takes a lot of time on skip_opencl_tests)
  • PR testsuite/25016 (Test-case failures for -pie)

comment:3 by Bruce Dubbs, 22 months ago

Resolution: fixed
Status: assignedclosed

Fixed at revision 22185.

Note: See TracTickets for help on using tickets.