Opened 19 years ago

Closed 17 years ago

Last modified 8 years ago

#134 closed defect (fixed)

cpio-2.6

Reported by: larry@… Owned by: Randy McMurchy
Priority: normal Milestone:
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

Change History (8)

comment:1 by larry@…, 19 years ago

Resolution: fixed
Status: newclosed

comment:2 by matthew@…, 17 years ago

Priority: highnormal
Resolution: fixed
Status: closedreopened
Summary: cpio-2.5cpio-2.6
Version: CVSSVN

Version increment (2.6)

comment:3 by Randy McMurchy, 17 years ago

Owner: changed from larry@… to Randy McMurchy
Status: reopenednew

comment:4 by Randy McMurchy, 17 years ago

Status: newassigned

comment:5 by Randy McMurchy, 17 years ago

The 'mt' program is not installed by default any longer. Additionally, if you try to manually build it, the build fails. The 'mt' man page is installed, so I'm wondering if it's just a problem with the package. I've sent an email to the maintainers. I'll wait a few days to see if there's any response before doing anything else.

comment:6 by Randy McMurchy, 17 years ago

A note from the maintainer follows:

Hi Randy,

Thanks for noticing the problem.

1) The mt program does not get built or installed. Was this by design, or did somehow my system not pass the correct flags

It is temporarily disabled in configure. To get it compiled configure the package as follows:

./configure CPIO_MT_PROG=mt

  1. If I change directories to src and run make mt, the program

fails at these lines:

i = argmatch (argv[optind], opnames); if (i < 0)

{

invalid_arg ("tape operation", argv[optind], i);

My mistake. Change invalid_arg' to argmatch_invalid'. Sorry for inconvenience.

Regards, Sergey

comment:7 by Randy McMurchy, 17 years ago

Resolution: fixed
Status: assignedclosed

Updated BLFS to cpio-2.6

comment:8 by bdubbs@…, 8 years ago

Milestone: old

Milestone old deleted

Note: See TracTickets for help on using tickets.