Opened 4 months ago

Closed 4 months ago

#14890 closed defect (invalid)

Failure starting X/lxdm with glib 2.68.0

Reported by: Tim Tassonis Owned by: blfs-book
Priority: normal Milestone: 10.2
Component: BOOK Version: SVN
Severity: normal Keywords:
Cc:

Description

I just tried to upgrade my qemu virtual machine to glib 2.68.0, which lead to lxdm/X not starting anymore. /var/log/lxdm.log reports:

MESA-LOADER: failed to open bochs-drm: /opt/X11/lib/dri/bochs-drm_dri.so: cannot open shared object file: No such file or directory (search paths /opt/X11/lib/dri) failed to load driver: bochs-drm

The file /opt/X11/lib/dri/bochs-drm_dri.so really does not exist, but with older glib (2.66.8) this is no problem.

A downgrade to glib 2.66.8 does actually fix the problem, so glib 2.68.0 really seems to be the problem here. I will try to investigate further, but for the moment, I would advise people to stay away from glib 2.68.0, at least on qemu vm's running X.

Change History (1)

comment:1 by Tim Tassonis, 4 months ago

Resolution: invalid
Status: newclosed
Note: See TracTickets for help on using tickets.